Project

General

Profile

Actions

action #90581

closed

[sle][migration][sle15sp3][regression] test fails in post_migration - no candidate needle with tag(s) displaymanager

Added by coolgw almost 3 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2021-04-01
Due date:
% Done:

100%

Estimated time:
16.00 h
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP3-Regression-on-Migration-from-SLE15-SPx-aarch64-online_slehpc15sp2_pscc_basesys-desk-dev-hpc-python2-srv-wsm_def_full_zpper_ld@aarch64 fails in
post_migration

Test suite description

The base test suite is used for job templates defined in YAML documents. It has no settings of its own.

Reproducible

Fails since (at least) Build 124.5

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest


Related issues 1 (0 open1 closed)

Related to openQA Tests - action #93528: [SLE][Migration][SLE15SP4][Regression] - do cleanup and reset the test env after check_upgarded_serviceResolvedhjluo2021-06-07

Actions
Actions #1

Updated by okurz almost 3 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: online_slehpc15sp2_pscc_basesys-desk-dev-hpc-python2-srv-wsm_def_full_zpper_ld
https://openqa.suse.de/tests/5784792

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed
Actions #3

Updated by hjluo over 2 years ago

set DESKTOP=textmode
./hj-tools/hj-clone.sh -j 5991291 -s "_GROUP=0 DESKTOP=textmode"

http://openqa.nue.suse.com/t6171267
http://openqa.nue.suse.com/t6171268

Actions #4

Updated by hjluo over 2 years ago

./hj-tools/hj-clone.sh -j 5991291 -s "_GROUP=0 EXCLUDE_MODULES=install_service,check_upgraded_service"
https://openqa.nue.suse.com/t6172230 PASSED

Actions #5

Updated by hjluo over 2 years ago

./hj-tools/hj-clone.sh -j 5991291 -s "_GROUP=0 INCLUDE_SERVICES=apache2,apparmor"
https://openqa.nue.suse.com/t6174201 PASSED
https://openqa.nue.suse.com/t6174202 PASSED

Actions #6

Updated by hjluo over 2 years ago

  • % Done changed from 10 to 20

tried to exclude users from service check
./hj-tools/hj-clone.sh -j 5991291 -s "_GROUP=0 EXCLUDE_SERVICES=users"
https://openqa.nue.suse.com/t6190357 PASSED
https://openqa.nue.suse.com/t6190381 PASSED

Actions #7

Updated by hjluo over 2 years ago

./hj-tools/hj-branch.sh -b post_mig -j 5991291 -s "_GROUP=0 INCLUDE_SERVICES=users"
https://openqa.nue.suse.com/t6191676
https://openqa.nue.suse.com/t6191677

Actions #8

Updated by hjluo over 2 years ago

./hj-tools/hj-clone.sh -j 5991291 -s "_GROUP=0 INCLUDE_SERVICES=users"
https://openqa.nue.suse.com/t6193169

Actions #9

Updated by hjluo over 2 years ago

  • % Done changed from 20 to 30

after discussing with Lemon, we've found the root cause for the issue is that during users service check before migration, the user
'test' was still login in and we'd need reset_console if the user unlocks was failed/stalled.

./hj-tools/hj-clone.sh -j 5991291 -s "_GROUP=0 INCLUDE_SERVICES=users"
https://openqa.nue.suse.com/t6201478
https://openqa.nue.suse.com/t6201496

Actions #10

Updated by hjluo over 2 years ago

./hj-tools/hj-clone.sh -j 5991291 -s "_GROUP=0 INCLUDE_SERVICES=users"
https://openqa.nue.suse.com/t6209859
https://openqa.nue.suse.com/t6209864

Actions #11

Updated by hjluo over 2 years ago

./hj-tools/hj-branch.sh -b post_mig -j 5991291 -s "_GROUP=0 INCLUDE_SERVICES=users"

https://openqa.nue.suse.com/t6210016
https://openqa.nue.suse.com/t6210861
https://openqa.nue.suse.com/t6211462

Actions #12

Updated by hjluo over 2 years ago

  • Status changed from In Progress to Rejected
  • % Done changed from 30 to 100

after discussed with Lemon, we'd reject this ticket for another service check cleanup ticket. cause the reason is that users login hasn't been cleaned when the exception happened.

https://progress.opensuse.org/issues/93528
[SLE][Migration][SLE15SP4][Regression] - do cleanup and reset the test env after check_upgarded_service

Actions #13

Updated by hjluo over 2 years ago

  • Related to action #93528: [SLE][Migration][SLE15SP4][Regression] - do cleanup and reset the test env after check_upgarded_service added
Actions

Also available in: Atom PDF