Project

General

Profile

action #90305

[qe-core] Plasma packagekit applet confused - test fails in updates_packagekit_kde

Added by apappas 10 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2021-03-18
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

The applet is slow to change the app indicator from the "updates available/updates installing" to the "updates none". The test doesnt wait enough time and gets confused as a result.

openQA test in scenario opensuse-15.2-DVD-Updates-x86_64-kde@64bit-2G fails in
updates_packagekit_kde

Test suite description

TIMEOUT_SCALE property is added to avoid sporadic shutdown fails in kde@USBboot_64 scenario.

Added by : oorlov;

Related ticket: poo#37000

Reproducible

Fails since (at least) Build 20210316-4

Expected result

Last good: 20210316-3 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by apappas 10 months ago

  • Subject changed from [qe-core] Plasma packagekit applet confuses - test fails in updates_packagekit_kde to [qe-core] Plasma packagekit applet confused - test fails in updates_packagekit_kde

The fix reorders the way the test checks if the tray indicator is still in an "updates available" after updates have already been applied.
Before the test checked if it was in the "available" state, and if it was, checked again.
Now the test checks it is in the "available" state and then if it is, checks if it is in the "no updates" state.
If there really are updates then that check will fail and the test will move to the updating state.
If there are not, the test will conclude.

PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/12221

#2 Updated by apappas 10 months ago

  • Status changed from In Progress to Resolved

PR merged.

#3 Updated by szarate 10 months ago

  • Tags set to outofsprint

#4 Updated by szarate 9 months ago

  • Target version set to QE-Core: Ready

#5 Updated by szarate 9 months ago

  • Target version changed from QE-Core: Ready to Ready

#6 Updated by szarate 9 months ago

  • Target version changed from Ready to QE-Core: Ready

Also available in: Atom PDF