Project

General

Profile

action #89990

Error on tests/kernel/run_ltp.pm: Can't locate sle/tests/kernel/run_ltp.pm

Added by pcervinka 4 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2021-03-12
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP3-Online-x86_64-ltp_openposix@64bit fails in
boot_ltp

Test suite description

A vast number of tests which ensure compliance with POSIX standards. This tests libc (user land) more than the kernel, but libc is the primary user for much of the kernel API.
_QUIET_SCRIPT_CALLS=1 poo#55238

Reproducible

Fails since (at least) Build 160.2 (current job)

Expected result

Last good: 160.2 (or more recent)

Further details

Always latest result in this scenario: latest

LTP tests started to fail with error:

info] ::: basetest::runtest: # Test died: error on tests/kernel/run_ltp.pm: Can't locate sle/tests/kernel/run_ltp.pm in @INC (you may need to install the sle::tests::kernel::run_ltp module) 
(@INC contains: sle/tests/kernel sle/lib /var/lib/openqa/pool/4/blib/arch /var/lib/openqa/pool/4/blib/lib /usr/lib/os-autoinst /usr/lib/perl5/site_perl/5.26.1/ppc64le-linux-thread-multi /usr/lib/perl5/site_perl/5.26.1 /usr/lib/perl5/vendor_perl/5.26.1/ppc64le-linux-thread-multi /usr/lib/perl5/vendor_perl/5.26.1 /usr/lib/perl5/5.26.1/ppc64le-linux-thread-multi /usr/lib/perl5/5.26.1 /usr/lib/perl5/site_perl) at (eval 156) line 1.

Could be caused by https://github.com/os-autoinst/openQA/pull/3712


Related issues

Related to openQA Project - coordination #67723: [epic] Remote openQA worker fails to run tests from openqa-clone-custom-git-refspecResolved2021-03-18

History

#1 Updated by pcervinka 4 months ago

  • Related to coordination #67723: [epic] Remote openQA worker fails to run tests from openqa-clone-custom-git-refspec added

#2 Updated by okurz 4 months ago

  • Status changed from New to In Progress
  • Assignee set to okurz
  • Priority changed from Normal to Urgent
  • Target version set to Ready

#3 Updated by okurz 4 months ago

Reverted this PR for now and will deploy to osd as soon as a package is available: https://github.com/os-autoinst/openQA/pull/3786

#4 Updated by okurz 4 months ago

  • Status changed from In Progress to Feedback
  • Priority changed from Urgent to Normal

okurz: fix is rolled out. Can you confirm? Also, we have not seen an alert internally so I wonder how we could better see and prevent the issues that you encountered
mdoucha: I can confirm LTP tests are working now. The tests failed when boot_ltp tried to schedule additional test modules at runtime so it wasn't a classic incomplete job.
mdoucha: You should probably run a round of LTP tests on known good QCOW image (without kernel update) as a pre-deployment sanity check.
okurz: Well, now we know that we can run LTP tests for the PR and maybe even automatically every time. But I wonder how we could also detect it after deployment. The tests you mentioned failed, not incompleted, right?
mdoucha: You could scan for unusual numbers of failed jobs, especially ones that fail very rarely
okurz: yeah, that's what I thought, something like a sudden change in statistics. Good idea
mdoucha: [you could] also checked for failures due to unexpected system error vs. standard assertion failure in test.

#5 Updated by okurz 3 months ago

  • Status changed from Feedback to Resolved

In the meantime we have also https://github.com/os-autoinst/openQA/pull/3817 deployed which sets relative directories as default (https://openqa.opensuse.org/tests/1700802/file/vars.json being just one example) and no problems have been reported so I see this task here as resolved as well.

Also available in: Atom PDF