Project

General

Profile

action #89056

incomplete jobs with auto_review:"isotovideo died: isotovideo received signal HUP":retry

Added by okurz 7 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2021-02-24
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

See for example https://openqa.suse.de/tests/5515263

Steps to reproduce

Find jobs referencing this ticket with the help of
https://raw.githubusercontent.com/os-autoinst/scripts/master/openqa-query-for-job-label ,
to look for this ticket call openqa-query-for-job-label poo#89056

History

#1 Updated by okurz 7 months ago

  • Assignee set to okurz

#2 Updated by okurz 7 months ago

  • Assignee deleted (okurz)
  • Priority changed from Urgent to Normal

Trying to handle current occurences with auto-review by triggering a manual pipeline on https://gitlab.suse.de/openqa/auto-review/-/pipelines : https://gitlab.suse.de/openqa/auto-review/-/pipelines/102136

Done, jobs are handled by auto-review now, decreasing prio and unassigning again

#3 Updated by okurz 7 months ago

  • Description updated (diff)

#4 Updated by mkittler 7 months ago

  • Status changed from New to In Progress
  • Assignee set to mkittler

We have 85 affected jobs:

select count(id) from jobs where reason like '%isotovideo received signal HUP%';
 count 
-------
    85

As long as this number doesn't increase we're actually fine because it means the fix #80908#note-17 works. (The fix couldn't take effect before the deployment of itself so the incompletes we saw so far are expected.)

#5 Updated by mkittler 7 months ago

  • Status changed from In Progress to Feedback

I don't think there's anything left to do, see #80908#note-18. I can keep the ticket open a little bit longer for monitoring but I actually already provoked the problem during my tests so we should have seen further incompletes by now if it would still happen.

#6 Updated by mkittler 7 months ago

  • Status changed from Feedback to Resolved

There are no further occurrences after the deployment today.

Also available in: Atom PDF