Project

General

Profile

action #88297

Manage password for multiple test users in os-autoinst for openQA tests

Added by leli 8 months ago. Updated 8 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
-
Start date:
2021-01-28
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

User story

As a QA engineer, I need to add a user change password test during migration process, that is to change password of bernhard and create a new user before migration, check the new password still worked and switch user after migration then. After I changed the bernhard's password in base system, I need to make sure the later Authority pass with correct password, while the later modules such as first_boot, system_prepare, prepare_test_data etc., they require input different password for different users. OpenQA only holds one password and doesn't distinguish users, that's why I file this ticket.

Acceptance criteria

  1. We can easily set new password for user in openQA and don't need touch passwords for other users.
  2. Do not affect existing test.

Tasks

Store password for each users in os-autoinst, and use different password for type_password according to different users.

Further details

For example, when use type_password without parameter, it will use the $testapi::password which doesn't distinguish user. This will make us hard to deal with password in openQA if I changed the password of bernhard in system, we have to update the openQA password with $testapi::password= after that to match different password requirement(sometimes need login bernhard, sometimes need login root).
I would say why type_password with parameter doesn't work for my requirement. Let use the handle_login as example, it check user by console type, then type_password, so the user and password are dealed separately, I can't simply just type_password with my new password to fix the issue.


Related issues

Is duplicate of openQA Project - action #88247: manage password for multiple test users in os-autoinst for openQA testsResolved2021-01-27

History

#1 Updated by okurz 8 months ago

  • Is duplicate of action #88247: manage password for multiple test users in os-autoinst for openQA tests added

#2 Updated by okurz 8 months ago

  • Status changed from New to Rejected
  • Assignee set to okurz

duplicate of #88247 . I only meant that you would update the description, not create a new ticket.

Also available in: Atom PDF