Project

General

Profile

action #80690

[qem] Testing of packages in different codestreams but in one incident

Added by jbaier_cz 8 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
2020-12-03
Due date:
% Done:

0%

Estimated time:

Description

The problem

Initial info from S:M:229219 and additional information from Manuel Schnitzer:

@QAM please keep in mind that this update contains two systemd packages
for SUSE:SLE-12-SP2:Update and SUSE:SLE-12-SP5:Update.

We never had this case before where we had different codestreams for the same
package in one incident. We agreed with Vit to try out if it works out, but we
expect that tools might fail during testing. In that case I would like to kindly
ask you to document as soon as you run into issues while testing this update.
(Maybe in the test report or on a confluence page?) It needs to be somehow clear
what the actual issues were so that we can make plan how to tackle them in future.

We want to ship only one single patch to customers for one specific bug and
not multiple, just because we have this setup of codestreams. Customers
should be able to reliable rely on one patch id for one specific
problem. This issue was brought up by Adrian Schroeder in one of our
recent workshops.

The solution

As it turned out, the only issues there are probably just inside

  1. template generator

    2020/11/02 19:14:16 E SUSE:Maintenance:16890:229219 QAM.TeReGen.Input.OBS: Inconsistent submission for libsystemd0: 228-150.92.1 vs 228-157.18.1

  2. mtui

    I talked to Ednilson before and discussed this case with him. From what he told me, mtui reported installation issues, but he verified it manually.


Related issues

Related to QA - coordination #93871: [epic] support process improvement in maintenance requests: packages from different code streams with identical fix sets/features in a single incidentNew2020-12-04

Is duplicate of QA - action #93931: [tools][qem] MTUI support multiple versions of package in incidentResolved2021-06-14

Precedes QA - action #93934: [tools][qem] template generator - multiple package version in incidentResolved2020-12-04

History

#2 Updated by okurz 8 months ago

great. Thank you for visualizing your work.

#3 Updated by okurz 6 months ago

  • Target version changed from Ready to future

#4 Updated by jbaier_cz about 1 month ago

  • Related to coordination #93871: [epic] support process improvement in maintenance requests: packages from different code streams with identical fix sets/features in a single incident added

#5 Updated by jbaier_cz about 1 month ago

  • Precedes action #93934: [tools][qem] template generator - multiple package version in incident added

#6 Updated by jbaier_cz about 1 month ago

  • Is duplicate of action #93931: [tools][qem] MTUI support multiple versions of package in incident added

#7 Updated by jbaier_cz about 1 month ago

  • Status changed from New to Resolved
  • Target version changed from future to Ready

The template generator part is already done, additional needed changes are covered in a different ticket. The mtui part is entirely covered in a different ticket.

#8 Updated by cdywan about 1 month ago

  • Assignee set to jbaier_cz

Also available in: Atom PDF