Project

General

Profile

action #80220

test choses wrong product for installation

Added by syrianidou_sofia 11 months ago. Updated 11 months ago.

Status:
Rejected
Priority:
High
Assignee:
Target version:
SUSE QA - SLE 15 SP3
Start date:
2020-11-23
Due date:
% Done:

0%

Estimated time:

Description

Observation

For full iso on x86_64 and ppc, the products have changed, so the shortcuts for product selection during "Welcome" page have also changed.

So far, the shortcuts are chosen based on the code:

sub get_product_shortcuts {
    # We got new products in SLE 15 SP1
    if (is_sle '15-SP1+') {
        return (
            sles => (is_ppc64le() || is_s390x()) ? 'u'
            : is_aarch64() ? 's'
            : 'i',
            sled => 'x',
            sles4sap => is_ppc64le() ? 'i'
            : (is_sle('15-SP2+') && is_x86_64()) ? 't'
            : 'p',
            hpc => is_x86_64() ? 'g' : 'u',
            rt  => is_x86_64() ? 't' : undef
        );
    }

openQA test in scenario sle-15-SP3-Full-ppc64le-textmode_installation_minimal_role@ppc64le fails in
welcome

Reproducible

Fails since (at least) Build 85.2

Expected result

Last good: 78.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by syrianidou_sofia 11 months ago

  • Project changed from openQA Tests to qe-yast
  • Category deleted (Bugs in existing tests)

#2 Updated by riafarov 11 months ago

  • Target version set to SLE 15 SP3

#3 Updated by riafarov 11 months ago

  • Status changed from New to Rejected
  • Assignee set to riafarov

We got SUSE Manager product gone and now it's back, so no need to adjustments.

Also available in: Atom PDF