Project

General

Profile

action #80204

coordination #76861: Adjust test code for the new partitioner UI

Adjust lvm+resize_root scenario for the UI changes in the Expert Partitioner

Added by syrianidou_sofia 11 months ago. Updated 10 months ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
SUSE QA - SLE 15 SP3
Start date:
2020-11-23
Due date:
% Done:

0%

Estimated time:

Description

Observation

We have resize_partition method available now, but we might need to change some code to call it with expected parameters.

Test is executed with SLE 15 SP1 QU image: https://openqa.suse.de/tests/latest?arch=x86_64&distri=sle&flavor=Installer-DVD-QR&machine=64bit&test=lvm%2Bresize_root&version=15-SP1

So please make sure that this still works.

openQA test in scenario sle-15-SP3-Online-x86_64-lvm+resize_root@64bit fails in
partitioning_resize_root

Test suite description

Maintainer: okurz

Select LVM during installation and try to resize the root LV to span more than 40GB which is selected as default. See bsc#989976, bsc#1000165

Reproducible

Fails since (at least) Build 85.2

Expected result

Last good: 78.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by syrianidou_sofia 11 months ago

  • Subject changed from Adjust partitioning_resize_root module, using libyui REST API to Adjust lvm+resize_root scenario, using libyui REST API

#2 Updated by syrianidou_sofia 11 months ago

  • Subject changed from Adjust lvm+resize_root scenario, using libyui REST API to Adjust lvm+resize_root scenario for the UI changes in the Expert Partitioner

#3 Updated by syrianidou_sofia 11 months ago

  • Project changed from openQA Tests to qe-yast
  • Category deleted (Bugs in existing tests)

#4 Updated by riafarov 11 months ago

  • Target version set to SLE 15 SP3
  • Parent task set to #76861

#5 Updated by riafarov 11 months ago

  • Status changed from New to Blocked
  • Assignee set to riafarov

Methods needed here are implemented, so blocking and see if extra actions are required.

#6 Updated by riafarov 11 months ago

  • Description updated (diff)
  • Status changed from Blocked to Workable
  • Assignee deleted (riafarov)

#7 Updated by riafarov 11 months ago

  • Status changed from Workable to In Progress
  • Assignee set to riafarov

Grabing this one as I've modified validation module here: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/11531

Which will break SLE 15 SP1 test unless is adjusted along with SP3.

#8 Updated by riafarov 11 months ago

  • Status changed from In Progress to Feedback

#9 Updated by riafarov 10 months ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF