Project

General

Profile

action #77929

UI build bar alignment broken on index page

Added by okurz 9 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2020-11-15
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

See attached screenshot showing how build bars are not properly aligned on the right hand side and also exceed the visible space while there is free space unused. The "free space unused" is to ensure that all entries can be shown and the longest entry takes that space (not shown in screenshot).

Acceptance criteria

  • AC1: The right-hand side of all build bars are aligned
  • AC2: No obvious wasted screen space while keeping readability

Suggestions

  • Look into the history of the pages where we tried to fix similar problems already
  • Check for any obvious regressions
  • Try to fix the right-hand side of all build bars
  • Crosscheck that no other detrimental changes are introduced by your changes.
example of unalignment.png (41 KB) example of unalignment.png ilausuch, 2020-11-16 13:43
10807

History

#1 Updated by mkittler 8 months ago

  • Status changed from Workable to New

There's no screenshot attached.

#2 Updated by okurz 8 months ago

  • Status changed from New to Workable

Created a new screenshot that shows the longest entry of the page along with the build bar next to Aarch64 to exceed the visible space along with a horizontal scroll bar.

#3 Updated by ilausuch 8 months ago

10807

The example is missing. I provide a new one and working on this

#4 Updated by okurz 8 months ago

  • Target version changed from future to Ready

huh, again my screenshot isn't there? strange :D

Keep in mind that the target version is "future" so this ticket wasn't actually on our backlog. But ok, let's do it as an exception :)

Can you please set a due that you find reasonable as an estimate how long it should take until we have e.g. an according PR merged?

#6 Updated by okurz 8 months ago

that's not a link to the PR :D

#7 Updated by ilausuch 8 months ago

  • Status changed from In Progress to Feedback

I put this in feedback because in my development environment I don't have enough build on the index page to test this. If someone could test it will be nice.

#8 Updated by mkittler 8 months ago

For feedback, see https://github.com/os-autoinst/openQA/pull/3563#issuecomment-729631950 - but I think is is good enough. Note that it generally not a problem to import test data into your development environment (see https://github.com/Martchus/openQA-helper#create-postgresql-user-maybe-import-some-data).

#9 Updated by ilausuch 8 months ago

  • Status changed from Feedback to Resolved

The PR is merged

#10 Updated by okurz 8 months ago

  • Status changed from Resolved to Feedback

ilausuch wrote:

The PR is merged

yes, but please Please aware about our https://progress.opensuse.org/projects/qa/wiki#Definition-of-DONE
Especially issues we can not validate with self-tests within the source repo we should await verification on production instances. As this ticket comes from me I would most likely remember that we had that ticket in case my originally reported problem would not yet be fixed but especially for outside reporters we should give the reporter a chance to give the final approval if the issue was fixed according to that person's requirements or not.
At best just tomorrow on o3 we can check if the issue is gone.

#11 Updated by ilausuch 8 months ago

  • Status changed from Feedback to Resolved

I checked that yes, this solves the problem in production. I put the status to resolved

Also available in: Atom PDF