Project

General

Profile

action #75091

incomplete jobs with one of the isotovideo sub-processes receiving a signal and just terminating, no clue why or who/what triggered the termination

Added by okurz 6 months ago. Updated 6 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Concrete Bugs
Target version:
Start date:
2020-10-22
Due date:
% Done:

0%

Estimated time:
Difficulty:
hard

Description

Observation

For example
https://openqa.suse.de/tests/4864829/file/autoinst-log.txt
showing

[2020-10-21T19:31:38.817 CEST] [debug] <<< testapi::wait_still_screen(similarity_level=47, timeout=30, stilltime=3)
[2020-10-21T19:31:39.498 CEST] [debug] autotest received signal TERM, saving results of current test before exiting
[2020-10-21T19:31:39.509 CEST] [debug] [autotest] process exited: 1
[2020-10-21T19:31:39.509 CEST] [debug] THERE IS NOTHING TO READ 5 5 4
[2020-10-21T19:31:39.510 CEST] [debug] stopping command server 10509 because test execution ended
[2020-10-21T19:31:39.510 CEST] [debug] isotovideo: informing websocket clients before stopping command server: http://127.0.0.1:20123/wOZ5cESySrbitZid/broadcast
[2020-10-21T19:31:39.526 CEST] [debug] commands process exited: 0
[2020-10-21T19:31:39.627 CEST] [debug] done with command server
[2020-10-21T19:31:39.627 CEST] [debug] stopping autotest process 10516
[2020-10-21T19:31:39.627 CEST] [debug] done with autotest process
[2020-10-21T19:31:39.627 CEST] [debug] isotovideo failed
[2020-10-21T19:31:39.628 CEST] [debug] stopping backend process 10575
[2020-10-21T19:31:39.628 CEST] [debug] backend got TERM
[2020-10-21T19:31:39.629 CEST] [info] ::: OpenQA::Qemu::Proc::save_state: Saving QEMU state to qemu_state.json
[2020-10-21T19:31:40.697 CEST] [debug] Passing remaining frames to the video encoder
[2020-10-21T19:31:40.728 CEST] [debug] Waiting for video encoder to finalize the video
[2020-10-21T19:31:40.728 CEST] [debug] The built-in video encoder (pid 10634) terminated
[2020-10-21T19:31:40.730 CEST] [debug] QEMU: qemu-system-x86_64: terminating on signal 15 from pid 10575 (/usr/bin/isotovideo: backen)
[2020-10-21T19:31:40.731 CEST] [debug] sending magic and exit
[2020-10-21T19:31:40.930 CEST] [debug] done with backend process
10493: EXIT 1

so autotest reports that it "received signal TERM", no clue what sent that signal to autotest.

Workaround

retrigger


Related issues

Related to openQA Project - action #71188: job incomplete with auto_review:"backend died: QEMU exited unexpectedly, see log for details" and no other obvious information in the logfile what went wrongWorkable2020-09-10

History

#1 Updated by okurz 6 months ago

  • Related to action #71188: job incomplete with auto_review:"backend died: QEMU exited unexpectedly, see log for details" and no other obvious information in the logfile what went wrong added

#2 Updated by okurz 6 months ago

  • Target version set to future
  • Difficulty set to hard

Also available in: Atom PDF