Project

General

Profile

action #75067

save_needle minion task fails because "Your account has been blocked"

Added by Xiaojing_liu 9 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
Start date:
2020-10-22
Due date:
% Done:

0%

Estimated time:

Description

Observation

save_needle minion task failed on OSD, the error message is:

 "result" => {
    "error" => "<strong>Failed to save system-role-default-system-textmode-20201021.</strong><br><pre>Unable to push Git commit: remote: GitLab: Your account has been blocked.\nTo gitlab.suse.de:openqa/os-autoinst-needles-sles.git\n ! [remote rejected]       master -> master (pre-receive hook declined)\nerror: failed to push some refs to 'gitlab\@gitlab.suse.de:openqa/os-autoinst-needles-sles.git'</pre>"
  }

See more details in https://openqa.suse.de/minion/jobs?id=783852


Related issues

Related to openQA Infrastructure - action #35290: [tools] again needles could not be pushed from osd to gitlab.suse.de due to "account has been blocked" and apparently no monitoring alert about this was observedResolved2018-04-20

Related to openQA Infrastructure - action #42920: Gitlab user gets blocked: Try out gitlab deployment tokens for openQAResolved2018-10-25

Related to openQA Infrastructure - action #67213: pushing needles on osd to gitlab.suse.de failsResolved2020-05-25

Related to openQA Infrastructure - action #89047: Failed to commit needles, gitlab account blocked 2021-02-24Resolved2021-02-24

History

#1 Updated by Xiaojing_liu 9 months ago

  • Subject changed from save_needle minion task fails to save_needle minion task fails because "Your account has been blocked"

#2 Updated by Xiaojing_liu 9 months ago

Check the git status in OSD shows that

xiaojing@openqa:/var/lib/openqa/share/tests/sle/products/sle/needles> git status 
On branch master
Your branch is ahead of 'origin/master' by 3 commits.
  (use "git push" to publish your local commits)

nothing to commit, working tree clean

The we run sudo -u geekotest git push, it return error:

xiaojing@openqa:/var/lib/openqa/share/tests/sle/products/sle/needles> sudo -u geekotest git push
Enumerating objects: 13, done.
Counting objects: 100% (13/13), done.
Delta compression using up to 10 threads
Compressing objects: 100% (12/12), done.
Writing objects: 100% (12/12), 64.21 KiB | 9.17 MiB/s, done.
Total 12 (delta 3), reused 0 (delta 0), pack-reused 0
remote: GitLab: Your account has been blocked.
To gitlab.suse.de:openqa/os-autoinst-needles-sles.git
 ! [remote rejected]       master -> master (pre-receive hook declined)
error: failed to push some refs to 'gitlab@gitlab.suse.de:openqa/os-autoinst-needles-sles.git'

Oliver tried to unblock the account by loginning into gitlab.suse.de with credentials in a private browser. this way did not work.
Create a ticket in infra: https://infra.nue.suse.com/SelfService/Display.html?id=178757

#3 Updated by okurz 9 months ago

  • Related to action #35290: [tools] again needles could not be pushed from osd to gitlab.suse.de due to "account has been blocked" and apparently no monitoring alert about this was observed added

#4 Updated by okurz 9 months ago

  • Related to action #42920: Gitlab user gets blocked: Try out gitlab deployment tokens for openQA added

#5 Updated by okurz 9 months ago

  • Related to action #67213: pushing needles on osd to gitlab.suse.de fails added

#6 Updated by okurz 9 months ago

  • Project changed from openQA Project to openQA Infrastructure
  • Status changed from New to Feedback
  • Assignee set to okurz
  • Priority changed from Normal to Urgent
  • Target version set to Ready

This is something specific to our infrastructure though. Users see the same error message whenever they want to save needles, hence "Urgent".

Thank you for the infra ticket. Please keep in mind to add "[openqa]" in the subject line of these tickets so that EngInfra can properly prioritize these (based on the common agreement QE has with them). Also in "urgent" cases please add "[urgent]" additionally, so the subject should say "[openqa][urgent] The gitlab account which openqa.suse.de used in needle directory is blocked" but unfortunately we can not change the subject in existing tickets. I added a comment in the ticket.

Also there is https://infra.nue.suse.com/SelfService/Display.html?id=178670 which I am waiting for.

What we could do as a workaround is to disable automatic pushing, just saving and commiting needles but not pushing. As a fix we might want to try to delete the API key and create a new one.

I think the problem is that for SLE needle pushing we are still using the account from "nicksinger" and not "openqa-pusher", see ##67804 and #67213 . So I pinged nicksinger as well so that he could ensure his account is unblocked.

#7 Updated by okurz 9 months ago

  • Status changed from Feedback to Resolved

I followed up with #67804 and fixed the issue

#8 Updated by okurz 5 months ago

  • Related to action #89047: Failed to commit needles, gitlab account blocked 2021-02-24 added

Also available in: Atom PDF