Project

General

Profile

action #71551

unstable/flaky/sporadic t/04-scheduler.t test failing

Added by okurz 10 months ago. Updated 10 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2020-09-19
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Since recently t/04-scheduler.t is very unstable.
https://app.circleci.com/pipelines/github/os-autoinst/openQA/4269/workflows/ea59d97b-61bd-4e86-b593-3401b6678a7e/jobs/40930/steps shows

not ok 11 - job grab (WORKER_CLASS mismatch)
Subtest: job grab (WORKER_CLASS mismatch)
[DEBUG] +=----------------=+
[DEBUG] -> Scheduling new jobs.
[DEBUG]      Free workers: 1/1
[DEBUG]      Scheduled jobs: 2
[DEBUG] Scheduler took 0.05042s to perform operations and allocated 0 jobs
    ok 1 - job not grabbed due to default WORKER_CLASS
    ok 2 - no workers/jobs allocated
    not ok 3 - t_seen has not changed

    #   Failed test 't_seen has not changed'
    #   at t/04-scheduler.t line 306.
    #          got: '2020-09-18T19:42:26'
    #     expected: '2020-09-18T19:42:25'
    1..3
    # Looks like you failed 1 test of 3.

I can reproduce the same locally

Steps to reproduce

Probably reproducable locally with

make test TESTS=t/04-scheduler.t

Suggestions

Bisect where the regression comes from and fix that to be stable locally and within CI.


Related issues

Copied to openQA Project - action #71554: unstable/flaky/sporadic t/full-stack.t test failing in script waits on CircleCIResolved2020-09-19

History

#1 Updated by okurz 10 months ago

  • Copied to action #71554: unstable/flaky/sporadic t/full-stack.t test failing in script waits on CircleCI added

#2 Updated by okurz 10 months ago

  • Status changed from Workable to Feedback
  • Assignee set to okurz

https://github.com/os-autoinst/openQA/pull/3408 to remove the check completely for now. I think this is what mkittler also proposed as an alternative in case we can't fix it immediately.

#3 Updated by okurz 10 months ago

  • Status changed from Feedback to Resolved

PR merged. I think it's ok if we do not have that check for now. We have enough instabilities in other areas :)

Also available in: Atom PDF