Project

General

Profile

action #71368

25-cache-service.t fails after passing all tests

Added by cdywan about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2020-09-15
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

25-cache-service.t regularly finishes with a false negative:

# Looks like your test exited with -1 just after [...].
Dubious, test returned 255 [...]
All [...] subtests passed

On CircleCI this looks like so:

[06:18:54] t/25-cache-service.t ..       Dubious, test returned 255 (wstat 65280, 0xff00)
All 23 subtests passed 
[06:22:13]

Test Summary Report
-------------------
t/25-cache-service.t (Wstat: 65280 Tests: 23 Failed: 0)
  Non-zero exit status: 255
Files=1, Tests=23, 199.141 wallclock secs ( 0.08 usr  0.01 sys + 99.89 cusr  
4.69 csys = 104.67 CPU)
Result: FAIL

Steps to reproduce

make test TESTS=t/25-cache-service.t

Problem

All tests pass, but something is not being cleaned up and caused the entire test run to fail despite that.

Suggestion

  • Investigate the services started and stopped in t/25-cache-service.t
  • Track down what parts of clean-up are not done correctly

Workaround

  • This is not effectively failing CI because it's already considered unstable. Although the false negative is very consistent now.

History

#1 Updated by okurz about 1 year ago

  • Category set to Concrete Bugs
  • Target version set to Ready

Is that maybe a consequence of the time limit you introduced? Please fill the ticket description from https://progress.opensuse.org/projects/openqav3/wiki/#Defects

#2 Updated by cdywan about 1 year ago

  • Status changed from New to In Progress
  • Assignee set to cdywan

okurz wrote:

Is that maybe a consequence of the time limit you introduced? Please fill the ticket description from https://progress.opensuse.org/projects/openqav3/wiki/#Defects

No, that was only just merged ;-) This is the error you would usually see before CircleCI ended up killing the job (see #66664). I only filed it now after being certain it's a completely distinct issue.

https://github.com/os-autoinst/openQA/pull/3391

#3 Updated by cdywan about 1 year ago

  • Description updated (diff)

#4 Updated by okurz about 1 year ago

  • Status changed from In Progress to Resolved

merged and in combination with https://github.com/os-autoinst/openQA/pull/3400 this should not be ignored by CI anymore :)

Also available in: Atom PDF