Project

General

Profile

action #70942

[desktop][sle15sp3] test fails in xrdp_client

Added by zcjia over 1 year ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-09-04
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

Need to find out if this is a test issue or a product issue.

From https://openqa.suse.de/tests/4641681/file/serial0.txt :

[ 1014.598564] gnome-shell[1811]: [23:59:09:427] [2847:2853] [WARN][com.freerdp.crypto] - Certificate verification failure 'unable to get local issuer certificate (20)' at stack position 0
[ 1014.601558] gnome-shell[1811]: [23:59:09:427] [2847:2853] [WARN][com.freerdp.crypto] - CN = DESKTOP-QBH3Q7L
[ 1014.610774] gnome-shell[1811]: [23:59:09:427] [2847:2853] [ERROR][com.freerdp.crypto] - @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
[ 1014.622908] gnome-shell[1811]: [23:59:09:427] [2847:2853] [ERROR][com.freerdp.crypto] - @           WARNING: CERTIFICATE NAME MISMATCH!           @
[ 1014.625178] gnome-shell[1811]: [23:59:09:427] [2847:2853] [ERROR][com.freerdp.crypto] - @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
[ 1014.627145] gnome-shell[1811]: [23:59:09:427] [2847:2853] [ERROR][com.freerdp.crypto] - The hostname used for this connection (10.0.2.18:3389)
[ 1014.629136] gnome-shell[1811]: [23:59:09:427] [2847:2853] [ERROR][com.freerdp.crypto] - does not match the name given in the certificate:
[ 1014.638769] gnome-shell[1811]: [23:59:09:427] [2847:2853] [ERROR][com.freerdp.crypto] - Common Name (CN):
[ 1014.640527] gnome-shell[1811]: [23:59:09:427] [2847:2853] [ERROR][com.freerdp.crypto] -  DESKTOP-QBH3Q7L
[ 1014.642288] gnome-shell[1811]: [23:59:09:427] [2847:2853] [ERROR][com.freerdp.crypto] - A valid certificate for the wrong name should NOT be trusted!
[ 1014.650317] gnome-shell[1811]: [23:59:09:427] [2847:2853] [WARN][com.freerdp.crypto] - The VerifyCertificate callback is deprecated, migrate your application to VerifyCertificateEx
[ 1024.928915] gnome-shell[1811]: [23:59:19:758] [2847:2861] [ERROR][com.freerdp.channels.rdpgfx.client] - Unexpected gfx pdu end: Actual: 20, Expected: 32
[ 1026.186726] gnome-shell[1811]: [23:59:20:015] [2847:2861] [ERROR][com.freerdp.channels.rdpgfx.client] - context->SurfaceCommand failed with error 50
[ 1026.189683] gnome-shell[1811]: [23:59:20:015] [2847:2861] [ERROR][com.freerdp.channels.rdpgfx.client] - rdpgfx_decode_AVC444 failed with error 50
[ 1026.193303] gnome-shell[1811]: [23:59:20:016] [2847:2861] [ERROR][com.freerdp.channels.rdpgfx.client] - rdpgfx_decode failed with error 50!
[ 1026.210951] gnome-shell[1811]: [23:59:20:016] [2847:2861] [ERROR][com.freerdp.channels.rdpgfx.client] - rdpgfx_recv_wire_to_surface_1_pdu failed with error 50!
[ 1026.213604] gnome-shell[1811]: [23:59:20:016] [2847:2861] [ERROR][com.freerdp.channels.rdpgfx.client] - Error while processing GFX cmdId: RDPGFX_CMDID_WIRETOSURFACE_1 (0x0001)
[ 1026.216675] gnome-shell[1811]: [23:59:20:016] [2847:2861] [ERROR][com.freerdp.channels.rdpgfx.client] - rdpgfx_recv_pdu failed with error 50!
[ 1026.222951] gnome-shell[1811]: [23:59:20:025] [2847:2853] [ERROR][com.freerdp.core] - rdp_set_error_info:freerdp_set_last_error_ex ERRINFO_GRAPHICS_SUBSYSTEM_FAILED [0x0001112F]
[ 1026.233319] gnome-shell[1811]: [23:59:20:025] [2847:2853] [ERROR][com.freerdp.core.transport] - BIO_read returned a system error 104: Connection reset by peer
[ 1060.716507] sysrq: Show Blocked State
[ 1062.373990] gnome-shell[1811]: [23:59:56:203] [2847:2862] [WARN][com.freerdp.crypto] - Certificate verification failure 'unable to get local issuer certificate (20)' at stack position 0
[ 1062.376947] gnome-shell[1811]: [23:59:56:203] [2847:2862] [WARN][com.freerdp.crypto] - CN = DESKTOP-QBH3Q7L

openQA test in scenario sle-15-SP3-Online-x86_64-desktopapps-remote-desktop-xrdp-client1@64bit-virtio-vga fails in
xrdp_client

Test suite description

Maintainer: gwang@suse.com

Reproducible

Fails since (at least) Build 23.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by zcjia over 1 year ago

Compare with SLE15SP2 GM https://openqa.suse.de/tests/4342957/file/serial0.txt (which also has certificate error but test is passed) :

[  414.368605] gnome-shell[1875]: [02:13:39:219] [2930:2935] [ERROR][com.freerdp.crypto] - @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
[  414.371250] gnome-shell[1875]: [02:13:39:219] [2930:2935] [ERROR][com.freerdp.crypto] - @           WARNING: CERTIFICATE NAME MISMATCH!           @
[  414.379022] gnome-shell[1875]: [02:13:39:219] [2930:2935] [ERROR][com.freerdp.crypto] - @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
[  414.381369] gnome-shell[1875]: [02:13:39:219] [2930:2935] [ERROR][com.freerdp.crypto] - The hostname used for this connection (10.0.2.18:3389)
[  414.385318] gnome-shell[1875]: [02:13:39:219] [2930:2935] [ERROR][com.freerdp.crypto] - does not match the name given in the certificate:
[  414.393395] gnome-shell[1875]: [02:13:39:219] [2930:2935] [ERROR][com.freerdp.crypto] - Common Name (CN):
[  414.395175] gnome-shell[1875]: [02:13:39:219] [2930:2935] [ERROR][com.freerdp.crypto] -  DESKTOP-QBH3Q7L
[  414.396808] gnome-shell[1875]: [02:13:39:219] [2930:2935] [ERROR][com.freerdp.crypto] - A valid certificate for the wrong name should NOT be trusted!
[  429.397548] gnome-shell[1875]: libinput error: client bug: timer event3 debounce short: offset negative (-4ms)
[  430.422984] remmina[2930]: gtk_menu_detach(): menu is not attached
[  430.459712] gnome-shell[1875]: Running under Gnome Shell version 3.34.4
[  430.461363] gnome-shell[1875]: [02:13:39:085] [2930:2935] [INFO][com.freerdp.client.common.cmdline] - loading channelEx cliprdr
[  430.463319] gnome-shell[1875]: [02:13:39:085] [2930:2935] [INFO][com.freerdp.client.common.cmdline] - loading channelEx drdynvc
[  430.465238] gnome-shell[1875]: [02:13:39:210] [2930:2935] [INFO][com.freerdp.crypto] - creating directory /home/bernhard/.config/freerdp
[  430.481311] gnome-shell[1875]: [02:13:39:210] [2930:2935] [INFO][com.freerdp.crypto] - creating directory [/home/bernhard/.config/freerdp/certs]
[  430.484165] gnome-shell[1875]: [02:13:39:210] [2930:2935] [INFO][com.freerdp.crypto] - created directory [/home/bernhard/.config/freerdp/server]
[  430.495197] gnome-shell[1875]: [02:13:44:581] [2930:2935] [INFO][com.freerdp.gdi] - Local framebuffer format  PIXEL_FORMAT_BGRA32
[  430.497317] gnome-shell[1875]: [02:13:44:581] [2930:2935] [INFO][com.freerdp.gdi] - Remote framebuffer format PIXEL_FORMAT_BGRA32
[  430.499465] gnome-shell[1875]: [02:13:44:593] [2930:2935] [INFO][com.freerdp.channels.drdynvc.client] - Loading Dynamic Virtual Channel rdpgfx
[  430.504145] gnome-shell[1875]: [02:13:44:593] [2930:2935] [INFO][com.freerdp.channels.drdynvc.client] - Loading Dynamic Virtual Channel disp

#2 Updated by zcjia about 1 year ago

Tested on physical machine on SLE15SP3 Alpha2 and Tumbleweed, remmina can connect to windows via rdp.

So maybe a testcase issue, will investigate.

#3 Updated by zcjia about 1 year ago

After remmina update in in build 44.1, the behavior in sle15sp3 is the same as TW, in https://bugzilla.opensuse.org/show_bug.cgi?id=1169797 .

#4 Updated by openqa_review about 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: desktopapps-remote-desktop-xrdp-client1
https://openqa.suse.de/tests/4788045

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#5 Updated by openqa_review about 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: desktopapps-remote-desktop-xrdp-client2
https://openqa.suse.de/tests/4981857

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#6 Updated by okurz about 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: desktopapps-remote-desktop-xrdp-client1
https://openqa.suse.de/tests/5069010

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#7 Updated by okurz 12 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: desktopapps-remote-desktop-xrdp-client1
https://openqa.suse.de/tests/5150293

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#8 Updated by okurz 12 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: desktopapps-remote-desktop-xrdp-client1
https://openqa.suse.de/tests/5217955

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#9 Updated by GraceWang 11 months ago

  • Assignee set to GraceWang

According to the comment from https://bugzilla.opensuse.org/show_bug.cgi?id=1169797#c18
This issue is caused by the outdated Windows version.
Will working on updating the windows qcow version from windows-10-x86_64-1511@64bit_win.qcow2 to windows-10-x86_64-20H2@windows_bios_boot.qcow2

#12 Updated by okurz 10 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: desktopapps-remote-desktop-xrdp-client1
https://openqa.suse.de/tests/5500897

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#13 Updated by okurz 9 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: desktopapps-remote-desktop-xrdp-client2
https://openqa.suse.de/tests/5614005

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#14 Updated by okurz 8 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: desktopapps-remote-desktop-xrdp-client1
https://openqa.suse.de/tests/5786053

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

Also available in: Atom PDF