Project

General

Profile

action #70342

[sle][migration][SLE15SP3]: integrate change_password.pm into service check

Added by coolgw about 1 year ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Enhancement to existing tests
Target version:
-
Start date:
2020-08-21
Due date:
% Done:

100%

Estimated time:
20.00 h
Difficulty:

Description

After checking the process of change_password.pm, I proposal call this module before migration and after migration:
Before migration:
• Change_pwd
• Add user
• Reboot and switch new user

After migration:
• Switch new user
My assumption this module only support on 12x/15x

History

#1 Updated by coolgw about 1 year ago

  • Priority changed from Normal to Low

#2 Updated by leli 11 months ago

  • Assignee set to leli

#3 Updated by leli 11 months ago

This test is on Desktop, so we need ensure switch to desktop although we will put it in service test.

#4 Updated by leli 11 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 10

#5 Updated by coolgw 9 months ago

  • Priority changed from Low to Normal

#8 Updated by leli 8 months ago

  • % Done changed from 10 to 20

Add sleep before unlock desktop.

openqa-clone-custom-git-refspec https://github.com/lemon-suse/os-autoinst-distri-opensuse/tree/Add-multi-users-and-verify http://openqa.nue.suse.com/tests/5289660 -c "--apikey xxx --apisecret xxx" _GROUP=0 INCLUDE_SERVICES=users
Created job #5322593: sle-15-SP3-Regression-on-Migration-from-SLE15-SPx-x86_64-Build124.5-offline_sles15sp1_ltss_pscc_lp-we-basesys-srv-desk-dev-contm-lgm-py2-tsm-wsm_all_full@64bit -> http://openqa.nue.suse.com/t5322593

#9 Updated by okurz 8 months ago

leli wrote:

Add sleep before unlock desktop.

openqa-clone-custom-git-refspec https://github.com/lemon-suse/os-autoinst-distri-opensuse/tree/Add-multi-users-and-verify http://openqa.nue.suse.com/tests/5289660 -c "--apikey xxx --apisecret xxx" …

Little hint (not sure I gave that one to you in before): Better specify your API key and secret in ~/.config/openqa/client.conf . This way you don't need to specify the options and also you are less likely to leak your credentials

#10 Updated by leli 8 months ago

  • % Done changed from 20 to 40

It seems the install_service is ok now.
https://openqa.nue.suse.com/tests/5325752#live

#11 Updated by leli 8 months ago

It seems the install_service is ok now.
https://openqa.nue.suse.com/tests/5325752#live

okurz wrote:

leli wrote:

Add sleep before unlock desktop.

openqa-clone-custom-git-refspec https://github.com/lemon-suse/os-autoinst-distri-opensuse/tree/Add-multi-users-and-verify http://openqa.nue.suse.com/tests/5289660 -c "--apikey xxx --apisecret xxx" …

Little hint (not sure I gave that one to you in before): Better specify your API key and secret in ~/.config/openqa/client.conf . This way you don't need to specify the options and also you are less likely to leak your credentials

Oh, because this cmd run on other one's test machine, so I can't do that. Now on my own machine I have followed your suggestion. :) Thanks.

#12 Updated by leli 8 months ago

restart after create a new needle for displaymanager or multi users.
https://openqa.nue.suse.com/tests/5326479#details

#13 Updated by leli 8 months ago

set new bernhard password for prepare_test_data

http://openqa.nue.suse.com/tests/5341457#live

#14 Updated by leli 8 months ago

Add root password in consoletest_setup
http://openqa.nue.suse.com/tests/5341500#

#15 Updated by leli 8 months ago

Try to restore the old password of bernhard after check, https://openqa.nue.suse.com/tests/5357346

#16 Updated by leli 8 months ago

  • % Done changed from 40 to 60

Use passwd restore the bernhard's password to old one seems works now. http://openqa.nue.suse.com/tests/5368268#

#17 Updated by leli 7 months ago

Update code to avoid reboot, wait https://openqa.nue.suse.com/tests/5412945

#18 Updated by leli 7 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 60 to 100

Also available in: Atom PDF