Project

General

Profile

action #69967

[u] bootloader_uefi with openSUSE keys fails to boot

Added by dimstar over 2 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Normal
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 30
Start date:
2020-08-13
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-uefi-os@64bit fails in
bootloader_uefi

openSUSE Tumbleweed received the new updated shim-leap package with the new key being used. (after boothole)

openQA now needs to catch up with this change

Test suite description

Reproducible

Fails since (at least) Build 20200812 (current job)

Expected result

Last good: 20200810 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by SLindoMansilla over 2 years ago

  • Subject changed from bootloader_uefi with openSUSE keys fails to boot to [u] bootloader_uefi with openSUSE keys fails to boot
  • Assignee set to SLindoMansilla
  • Target version set to Milestone 30

#2 Updated by SLindoMansilla over 2 years ago

  • Status changed from New to Rejected

#3 Updated by mlin7442 over 2 years ago

  • Status changed from Rejected to New

Why? the fail test is about shim isn't up with opensuse signed ovmf, not MS key, MS key test has been passed. The ovmf bios(deployed in o3's worker) file is signed with old opensuse signkey, the signkey has been updated on OBS, after new updated shim-leap was introduced, the outdated ovmf bios doesn't work here, ie. /usr/share/qemu/ovmf-x86_64-opensuse-code.bin and vars.bin.

#4 Updated by SLindoMansilla over 2 years ago

mlin7442 wrote:

Why? the fail test is about shim isn't up with opensuse signed ovmf, not MS key, MS key test has been passed. The ovmf bios(deployed in o3's worker) file is signed with old opensuse signkey, the signkey has been updated on OBS, after new updated shim-leap was introduced, the outdated ovmf bios doesn't work here, ie. /usr/share/qemu/ovmf-x86_64-opensuse-code.bin and vars.bin.

ovmf is a package that is providing a file signed with the old openSUSE key. That is the bug. As Gary confirmed. Any user using Leap 15.1 as a host installing that package will have the same problem because the package installs the wrong file.

#5 Updated by mlin7442 over 2 years ago

SLindoMansilla wrote:

mlin7442 wrote:

Why? the fail test is about shim isn't up with opensuse signed ovmf, not MS key, MS key test has been passed. The ovmf bios(deployed in o3's worker) file is signed with old opensuse signkey, the signkey has been updated on OBS, after new updated shim-leap was introduced, the outdated ovmf bios doesn't work here, ie. /usr/share/qemu/ovmf-x86_64-opensuse-code.bin and vars.bin.

ovmf is a package that is providing a file signed with the old openSUSE key. That is the bug. As Gary confirmed. Any user using Leap 15.1 as a host installing that package will have the same problem because the package installs the wrong file.

Ah, I see your point, provide updated ovmf as maint. update then o3's worker will received these updates naturally along with Leap's maintenance channel. My statement is about we can carry TW's qemu-ovmf package and install it to o3's worker, then we don't need to wait for the next 15.1 maint update delivered :)

If get qemu-ovmf update via maint channel is preferred, I'm totally fine with it.

#6 Updated by SLindoMansilla over 2 years ago

  • Status changed from New to Rejected

ok :)

Rejected doesn't mean that is not going to be fix, it is just because the fix is done via the bugzilla ticket and not via this progress ticket

Also available in: Atom PDF