Project

General

Profile

action #69946

[tools] when needle does not exist, test is paused until MAX_JOB_TIME

Added by dzedro 12 months ago. Updated 10 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2020-08-12
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Test should not be paused [1] when the needle does not exist, jobs is then hanging (in this case 3 hours) until timeout_exceeded.

[2020-08-12T13:21:39.887 CEST] [debug] <<< testapi::check_screen(mustmatch="yast2-lan-really", timeout=3)
[2020-08-12T13:21:39.888 CEST] [debug] NO matching needles for yast2-lan-really
[2020-08-12T13:21:40.165 CEST] [debug] no match: 2.7s
[2020-08-12T13:21:41.166 CEST] [debug] no match: 1.7s
[2020-08-12T13:21:42.167 CEST] [debug] no match: 0.7s
[2020-08-12T13:21:43.168 CEST] [debug] no match: -0.3s
[2020-08-12T13:21:43.343 CEST] [debug] >>> testapi::_check_backend_response: match=yast2-lan-really timed out after 3 (check_screen)
[2020-08-12T13:21:43.365 CEST] [debug] isotovideo: pausing test execution on timeout as requested at console-yast2_lan
[2020-08-12T16:24:26.117 CEST] [debug] autotest received signal TERM, saving results of current test before exiting
[2020-08-12T16:24:26.117 CEST] [debug] isotovideo received signal TERM
[2020-08-12T16:24:26.118 CEST] [debug] backend got TERM

[1] https://github.com/os-autoinst/os-autoinst/blob/master/testapi.pm#L273
[2] https://openqa.suse.de/tests/4549187/file/autoinst-log.txt

openQA test in scenario sle-15-SP2-Desktop-DVD-Incidents-x86_64-qam-allpatterns@64bit fails in
yast2_lan

Test suite description

Default system config with all patterns enabled.
Due changes in autoyast profile size of HDD incerased to 40GB

Reproducible

Fails since (at least) Build :16068:freerdp

Expected result

Last good: :16063:emacs (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz 10 months ago

  • Project changed from openQA Tests to openQA Project
  • Category changed from Bugs in existing tests to Concrete Bugs
  • Status changed from New to Rejected
  • Assignee set to okurz
  • Target version set to Ready

Hi dzedro , I saw you added the "[tools]" keyword in the ticket. We within the SUSE QA Tools team struggle a bit to review tickets with this keyword as we primarily look into the project progress.opensuse.org/projects/openqav3/ .

If this really is the case then it's certainly unexpected behaviour. From the log it looks like that the test was paused from the developer mode or with a setting PAUSE_AT. The full job does not exist anymore unfortunately so I can't check vars.json as well. Later jobs in this scenario do look fine however. Please report back if you see this again.

Also available in: Atom PDF