Project

General

Profile

action #69832

[opensuse] test fails in bootloader_uefi - need to switch UEFI_PFLASH parameters to ovmf-x86_64-suse-code/vars.bin

Added by mlin7442 about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-08-11
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Jump:15.2-DVD-x86_64-uefi-os@64bit fails in
bootloader_uefi

Test suite description

Reproducible

Fails since (at least) Build 22.3

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

We need to add SLE built/signed ovmf bios files to o3 workers, I suppose we do have those ovmf files on osd's worker already? the reason is Jump's shim is reused SLE's shim without rebuild on OBS side, thus openSUSE built/signed ovmf bios can not success to verifying Jump's shim.

Have to switch UEFI_PFLASH parameters to ovmf-x86_64-suse-code/vars.bin since Jump's shim is from SLE.

History

#1 Updated by SLindoMansilla about 1 year ago

  • Subject changed from test fails in bootloader_uefi - need to add SLE built ovmf bios files to o3 workers for Jump project testing to [tools] test fails in bootloader_uefi - need to add SLE built ovmf bios files to o3 workers for Jump project testing

Someone with access to O3 is needed

#2 Updated by okurz about 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: install_only@aarch64-secureboot-opensuse-key
https://openqa.opensuse.org/tests/1388437

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#3 Updated by okurz about 1 year ago

  • Subject changed from [tools] test fails in bootloader_uefi - need to add SLE built ovmf bios files to o3 workers for Jump project testing to [functional][u] test fails in bootloader_uefi - need to add SLE built ovmf bios files to o3 workers for Jump project testing

SLindoMansilla wrote:

Someone with access to O3 is needed

yes, but that does not make it "tools".

I guess Jump uefi-os is also part of "[u]"?

This is what we have on a typical osd worker:

okurz@openqaworker10:~> for i in /usr/share/qemu/*.bin; do rpm -qf $i; done
qemu-seabios-1.12.0-lp151.7.15.2.noarch
qemu-seabios-1.12.0-lp151.7.15.2.noarch
qemu-x86-3.1.1.1-lp151.7.15.2.x86_64
qemu-x86-3.1.1.1-lp151.7.15.2.x86_64
qemu-x86-3.1.1.1-lp151.7.15.2.x86_64
qemu-x86-3.1.1.1-lp151.7.15.2.x86_64
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp151.11.6.1.noarch
qemu-sgabios-8-lp151.7.15.2.noarch
qemu-vgabios-1.12.0-lp151.7.15.2.noarch
qemu-vgabios-1.12.0-lp151.7.15.2.noarch
qemu-vgabios-1.12.0-lp151.7.15.2.noarch
qemu-vgabios-1.12.0-lp151.7.15.2.noarch
qemu-vgabios-1.12.0-lp151.7.15.2.noarch
qemu-vgabios-1.12.0-lp151.7.15.2.noarch
qemu-vgabios-1.12.0-lp151.7.15.2.noarch
qemu-vgabios-1.12.0-lp151.7.15.2.noarch
okurz@openqaworker10:~> zypper info qemu-ovmf-x86_64
Repository 'devel_openQA' is out-of-date. You can run 'zypper refresh' as root to update it.
Repository 'openSUSE-Leap-15.1-Update-Debug' is out-of-date. You can run 'zypper refresh' as root to update it.
Repository 'openSUSE-Leap-15.1-Update' is out-of-date. You can run 'zypper refresh' as root to update it.
Loading repository data...
Reading installed packages...


Information for package qemu-ovmf-x86_64:
-----------------------------------------
Repository     : openSUSE-Leap-15.1-Update
Name           : qemu-ovmf-x86_64
Version        : 2017+git1510945757.b2662641d5-lp151.11.6.1
Arch           : noarch
Vendor         : openSUSE
Installed Size : 57.4 MiB
Installed      : Yes
Status         : up-to-date
Source package : ovmf-2017+git1510945757.b2662641d5-lp151.11.6.1.src
Summary        : Open Virtual Machine Firmware - QEMU rom images (x86_64)
Description    : 
    The Open Virtual Machine Firmware (OVMF) project aims to support
    firmware for Virtual Machines using the edk2 code base.

    This package contains UEFI rom images for exercising UEFI secure
    boot in a qemu environment (x86_64)

And a typical test scenario
https://openqa.suse.de/tests/latest?arch=x86_64&distri=sle&flavor=Online&machine=uefi&test=default&version=15-SP3

so I don't think there is anything special or different done for OSD workers.

#4 Updated by mlin7442 about 1 year ago

  • Assignee set to mlin7442

I've chatted to Gary, seems we don't need a SLE side built qemu-ovmf, switch to ovmf-x86_64-suse-code/vars.bin should work since those should've SLE CA included. Re-assign to me for verification.

#5 Updated by mlin7442 about 1 year ago

  • Subject changed from [functional][u] test fails in bootloader_uefi - need to add SLE built ovmf bios files to o3 workers for Jump project testing to [functional][u] test fails in bootloader_uefi - need to switch UEFI_PFLASH parameters to ovmf-x86_64-suse-code/vars.bin
  • Description updated (diff)
  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Looks worked, https://openqa.opensuse.org/tests/1401298 https://openqa.opensuse.org/tests/1401385

2 new tests added to Jump jobgroup, and 2 tests be removed from this group.

#6 Updated by okurz about 1 year ago

  • Subject changed from [functional][u] test fails in bootloader_uefi - need to switch UEFI_PFLASH parameters to ovmf-x86_64-suse-code/vars.bin to [opensuse] test fails in bootloader_uefi - need to switch UEFI_PFLASH parameters to ovmf-x86_64-suse-code/vars.bin

ok, cool! So it was [opensuse] after all with a bit of tools from [tools] ;)

Also available in: Atom PDF