Project

General

Profile

action #69820

os-autoinst: unstable/flaky/sporadic test 28-signalblocker.t

Added by okurz 12 months ago. Updated 12 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2020-08-11
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

https://build.opensuse.org/package/live_build_log/devel:openQA/os-autoinst/openSUSE_Leap_15.1/x86_64 shows

[  162s] 3: ./27-make-update-deps.t .................. ok
[  162s] 3: 
[  162s] 3: #   Failed test 'no new threads after searching for a needle'
[  162s] 3: #   at ./28-signalblocker.t line 65.
[  162s] 3: #          got: '8'
[  162s] 3: #     expected: '9'
[  162s] 3: 
[  162s] 3: #   Failed test 'all threads still alive'
[  162s] 3: #   at ./28-signalblocker.t line 77.
[  162s] 3: #          got: '8'
[  162s] 3: #     expected: '9'
[  162s] 3: # Looks like you failed 2 tests of 6.
[  162s] 3: ./28-signalblocker.t ..................... 
[  162s] 3: Dubious, test returned 2 (wstat 512, 0x200)
[  162s] 3: Failed 2/6 subtests 
[  162s] 3: 
[  162s] 3: Test Summary Report
[  162s] 3: -------------------
[  162s] 3: ./28-signalblocker.t                   (Wstat: 512 Tests: 6 Failed: 2)
[  162s] 3:   Failed tests:  3, 5
[  162s] 3:   Non-zero exit status: 2
[  162s] 3: Files=30, Tests=844, 81 wallclock secs ( 0.34 usr  0.11 sys + 74.29 cusr  6.71 csys = 81.45 CPU)
[  162s] 3: Result: FAIL
[  162s] 3/3 Test #3: test-perl-testsuite ..............***Failed   81.86 sec
[  162s] 

Reproducible

unknown statistics so far

Acceptance criteria

  • AC1: 28-signalblocker.t is part of stable tests again in dist/rpm/os-autoinst.spec

Suggestions

  • Reproduce and find fail ratio
  • Fix for either special OBS environment or (better) within 28-signalblocker.t

History

#1 Updated by okurz 12 months ago

  • Description updated (diff)
  • Status changed from In Progress to Workable
  • Assignee deleted (okurz)
  • Priority changed from High to Low

#2 Updated by mkittler 12 months ago

  • Assignee set to mkittler

#3 Updated by okurz 12 months ago

  • Status changed from Workable to Resolved

PR merged. As the problem is likely to not happen often we can immediately resolve.

Also available in: Atom PDF