Project

General

Profile

tickets #69283

"count cache flush assist capability level not supported by kvm" since 20200721 5:04pm PowerPC builders

Added by michel_mno almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
opensuse-admin-obs
Category:
OBS
Target version:
-
Start date:
2020-07-23
Due date:
% Done:

0%

Estimated time:

Description

"count cache flush assist capability level not supported by kvm"
between 20200721 5:04pm and 20200722 1am for PowerPC builders

From coolo info in irc, bugfinder identified problem with PowerPC
workers updated to 15.2.
Bypass was to downgrade to 15.1

Is there already an open issue to track the problem ?

(09:57:57 AM) michel_mno: adrianS, do you know if there was a recent 
change on PowerPC builder ? There are many build failure with "Requested 
count cache flush assist capability level not supported by kvm, try 
appending -machine cap-ccf-assist=off" like 
https://build.opensuse.org/package/live_build_log/openSUSE:Factory:PowerPC/000release-packages:openSUSE-release/standard/ppc64
(10:02:16 AM) adrianS: michel_mno: hm, yes, I swiched the hosts :/
(10:02:27 AM) adrianS: michel_mno: seems the new one is too small .. 
will switch back
(10:02:35 AM) adrianS: and wait for hardware delivery ....
(10:05:32 AM) michel_mno: adrianS: is the new host the same model as 
previous ones ?
(10:07:23 AM) adrianS: michel_mno: typhoon2  has double space as typhoon5
(10:07:33 AM) adrianS: so your builds going back to typhoon2 now
(10:07:49 AM) adrianS: but we will increase the size of these systems 
anyway next week hopefully
(10:07:55 AM) adrianS: since it is quite a blocker atm
(10:10:46 AM) michel_mno: adrianS:  Hum, the above error message is not 
only on typhoon* but also on  powerPC builder  eg: 
https://build.opensuse.org/package/live_build_log/openSUSE:Factory:PowerPC/neomutt/standard/ppc64le
(10:36:14 AM) adrianS: michel_mno: ah, even usually package builds, hm ....
(10:52:28 AM) coolo: adrianS, michel_mno: bugfinder says he downgraded 
to 15.1 now.
(12:04:53 PM) michel_mno: coolo, is there an issue to track that failure 
? should I create one ?
(12:08:26 PM) ***coolo is only bouncing infos forth and back - but I ask 
bugfinder to join :)

--
Michel Normand

neomutt_standard_ppc64le_202007221137.log (5.21 KB) neomutt_standard_ppc64le_202007221137.log neomutt build failure on 20200721 michel_mno, 2020-07-27 16:23

History

#1 Updated by michel_mno almost 2 years ago

Could this issue be changed to public ?

#2 Updated by cboltz almost 2 years ago

  • Category set to OBS
  • Assignee set to opensuse-admin-obs
  • Private changed from Yes to No

#3 Updated by michel_mno almost 2 years ago

In attachment a build log that failed in above reported time frame.

I do not have such problem in a local ppc64le host installed with Leap 15.2.

#4 Updated by michel_mno almost 2 years ago

as today on the 7 PowerPC host builders, 3 seems to be installed with Leap15.1, and 4 with TW ?

$for xx in 8-01 8-02 8-03 8-04 8-05 9-06 9-07; do osc api  /worker/ppc64le:obs-power${xx}:1 |grep version; done
    <version>4.12.14-lp151.28.52</version>
    <version>4.12.14-lp151.28.52</version>
    <version>4.12.14-lp151.28.52</version>
    <version>5.7.9-1</version>
    <version>5.7.9-1</version>
    <version>5.7.9-1</version>
    <version>5.7.9-1</version>

What steps to have them populated with Leap15.2 ?

#5 Updated by oertel almost 2 years ago

the problem is ... the 15.2 kernel has other issues, it usually just stalls after 48 hours or so without any message.
so I'm trying to get to the TW kernel directly and now in TW qemu-5.0.0 is giving other issues.
Actually I've added a hack to the build script that should work around the issue:

https://github.com/openSUSE/obs-build/pull/585

do you still see the problem ?

#6 Updated by michel_mno almost 2 years ago

Thank you for the information.
No I do not have the problem anymore. experienced only in "20200721 5:04pm to 20200722 1am" time frame.

#7 Updated by michel_mno almost 2 years ago

Suggest to close this issue, and track
current PowerPC worker problems with:

#8 Updated by oertel almost 2 years ago

  • Status changed from New to Closed

closing, I'm keeping track of crashing machines and the rest is handled in the bugs mentioned above.

Also available in: Atom PDF