Project

General

Profile

action #68522

test fails in valgrind

Added by dimstar over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-06-30
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-extra_tests_in_textmode@64bit fails in
valgrind

Valgrind has been updated to version 3.16.0 - according to the changelog, there are a few backward-incompatible changes, which might well affect our test cases.

Test suite description

Maintainer: okurz@suse.de

Mainly console extratest.

Reproducible

Fails since (at least) Build 20200610

Expected result

Last good: 20200610 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by ph03nix over 2 years ago

  • Status changed from New to In Progress
  • Assignee set to ph03nix

#2 Updated by ph03nix over 2 years ago

Last good run was Build 20200627 or test 1318849. All tests afterwards consistently failing with

valgrind: failed to start tool 'exp-sgcheck' for platform 'amd64-linux': No such file or directory

See e.g. this one

#3 Updated by ph03nix over 2 years ago

exp-sgcheck has been remove since it was causing lots of false positives and gcc/clang ASAN provides better debugging capabilities. Adjusting the test accordingly.

#5 Updated by ph03nix over 2 years ago

Merged: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/10677
Awaiting next test runs for verification before closing.

#6 Updated by ph03nix over 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

Also available in: Atom PDF