Project

General

Profile

action #6784

Test marked 'failed' without apparent reason

Added by dimstar over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2015-03-19
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

This is something I have seen more often lately, but surprisingly only on the rescuesystem tests (maybe because it's so short-living?)

A sample run:
https://openqa.opensuse.org/tests/52724

The step "rescuesystem_validate_131" has no return value; in autoinst-log.txt, it is visible that the awaited serial string has been seen (can also be confirmed in serial.txt)

The end of the log:
`Debug: /var/lib/openqa/share/tests/opensuse/tests/installation/rescuesystem_validate_131.pm:10 called testapi::type_string
<<< type_string(string=$VAR1 = '\'cat /mnt/etc/SUSE-brand > /dev/ttyS0
\'';
, max_interval=$VAR1 = '\'250\'';
)
Debug: /var/lib/openqa/share/tests/opensuse/tests/installation/rescuesystem_validate_131.pm:11 called testapi::wait_serial
<<< wait_serial(regex=$VAR1 = 'VERSION = 13.1';
, timeout=$VAR1 = 2;
)

wait_serial: VERSION = 13.1: ok
||| finished rescuesystem_validate_131 installation at 2015-03-18 23:12:39 (6 s)
isotovideo done
waitpid for 15800 returned 0
sending TERM to qemu pid: 15800
waitpid for 15800 returned 15800
QEMU: qemu: terminating on signal 15 from pid 15757
sending magic and exit
received magic close
killing commands thread
done joining commands thread
+++ worker notes +++
end time: 2015-03-18 23:12:52
result: done`

History

#1 Updated by coolo over 7 years ago

  • Category set to Concrete Bugs
  • Target version set to Sprint 15

#2 Updated by coolo over 7 years ago

I figured what the problem is. the last test is just too quickly done and when the worker sees the results.json running is ''.

#3 Updated by coolo over 7 years ago

  • Status changed from New to Resolved
  • Assignee set to coolo

Also available in: Atom PDF