Project

General

Profile

action #67285

[y] Adjust installation in autoyast_salt to the recent changes

Added by ybonatakis over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - SLE 15 SP2
Start date:
2020-05-26
Due date:
2020-06-16
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

now we support several formulas (suse manager and not suse manager), several pillars etc.
in order to make everything consistent, we changed how the salt.tar.gz is organized, and the "formulas" directories has now two directories (states and metadata).
the changes are https://github.com/yast/yast-configuration-management/pull/81 and https://github.com/yast/yast-configuration-management/pull/80.

in theory we would need to update the tar file with the new structure. The rest should remain the same(xml, installation flow)

Contact to IGonzalezSosa for support

openQA test in scenario sle-15-SP2-Online-x86_64-autoyast_salt@64bit fails in
installation

Test suite description

Test installation using AutoYaST plus salt formulas.

Reproducible

Fails since (at least) Build 202.5

Expected result

Last good: 201.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by IGonzalezSosa over 1 year ago

Hi all,

I have just opened a PR that contains the new layout for the TAR. The idea is that our formulas have the same structure that the ones used by SUSE Manager, having "formulas/states" and "formulas/metadata". You can find more information about them in the SUMA Best Practices.

#2 Updated by ybonatakis over 1 year ago

#3 Updated by riafarov over 1 year ago

  • Due date set to 2020-06-16
  • Priority changed from Normal to High
  • Target version set to SLE 15 SP2

#4 Updated by riafarov over 1 year ago

  • Status changed from New to Workable
  • Assignee set to ybonatakis

#5 Updated by ybonatakis over 1 year ago

  • Status changed from Workable to In Progress

#6 Updated by ybonatakis over 1 year ago

  • Status changed from In Progress to Feedback

merged

#7 Updated by riafarov over 1 year ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF