Project

General

Profile

action #66066

coordination #39719: [saga][epic] Detect "known failures" and mark jobs as such to make tests more stable, reviewing test results and tracking known issues easier

coordination #62420: [epic] Distinguish all types of incompletes

incomplete with reason "died: terminated prematurely" but log shows error 404 failing to download asset into cache auto_review:"(?s)Download.*failed: 404.*No scripts"

Added by okurz 9 months ago. Updated 9 months ago.

Status:
Rejected
Priority:
High
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2020-04-25
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

https://openqa.suse.de/tests/4163236# is incomplete, reason "died: terminated prematurely, see log output for details" . Log content:

[2020-04-25T04:08:30.0771 CEST] [info] [pid:48568] +++ setup notes +++
[2020-04-25T04:08:30.0771 CEST] [info] [pid:48568] Running on openqaworker9:23 (Linux 4.12.14-lp151.28.40-default #1 SMP Fri Mar 6 13:48:15 UTC 2020 (f0f1262) x86_64)
[2020-04-25T04:08:30.0779 CEST] [debug] [pid:48568] Found HDD_1, caching SLE-12-SP4-x86_64-Build20200425-1-qam-sle_sap-gnome.qcow2
[2020-04-25T04:08:30.0781 CEST] [info] [pid:48568] Downloading SLE-12-SP4-x86_64-Build20200425-1-qam-sle_sap-gnome.qcow2, request #15457 sent to Cache Service
[2020-04-25T04:08:40.0894 CEST] [info] [pid:48568] Download of SLE-12-SP4-x86_64-Build20200425-1-qam-sle_sap-gnome.qcow2 processed:
[info] [#15457] Cache size of "/var/lib/openqa/cache" is 49GiB, with limit 50GiB
[info] [#15457] Downloading "SLE-12-SP4-x86_64-Build20200425-1-qam-sle_sap-gnome.qcow2" from "http://openqa.suse.de/tests/4163236/asset/hdd/SLE-12-SP4-x86_64-Build20200425-1-qam-sle_sap-gnome.qcow2"
[info] [#15457] Download of "/var/lib/openqa/cache/openqa.suse.de/SLE-12-SP4-x86_64-Build20200425-1-qam-sle_sap-gnome.qcow2" failed: 404 Not Found

[2020-04-25T04:08:40.0895 CEST] [error] [pid:48568] Failed to download SLE-12-SP4-x86_64-Build20200425-1-qam-sle_sap-gnome.qcow2 to /var/lib/openqa/cache/openqa.suse.de/SLE-12-SP4-x86_64-Build20200425-1-qam-sle_sap-gnome.qcow2
[2020-04-25T04:08:41.0122 CEST] [debug] [pid:46669] +++ worker notes +++
[2020-04-25T04:08:41.497 CEST] [debug] Current version is 4.6.1586871095.50464d4e [interface v20]
No scripts in HASH(0x55de6a946f98)/sle at /usr/lib/os-autoinst/bmwqemu.pm line 181.
46669: EXIT 1
[2020-04-25T04:08:41.0506 CEST] [info] [pid:48568] Isotovideo exit status: 1
[2020-04-25T04:08:41.0531 CEST] [info] [pid:48568] +++ worker notes +++
[2020-04-25T04:08:41.0531 CEST] [info] [pid:48568] End time: 2020-04-25 02:08:41
[2020-04-25T04:08:41.0531 CEST] [info] [pid:48568] Result: died: terminated prematurely, see log output for details
[2020-04-25T04:08:41.0559 CEST] [info] [pid:46671] Uploading vars.json
[2020-04-25T04:08:41.0592 CEST] [info] [pid:46671] Uploading autoinst-log.txt

Expected result

  • Reason should point to not downloadable asset, not "died" even though there is a later error about "No scripts in HASH(0x55de6a946f98)/sle" which should be addressed by https://github.com/os-autoinst/openQA/pull/2973 (merged but not deployed to osd at the time of reporting)

Suggestions

  • Look if the error about "No scripts in" is overriding any former reason about 404
  • Ensure 404 errors yield a proper reason for the incomplete job (regardless of the potential followup error)

Related issues

Is duplicate of openQA Project - action #65840: auto_review:"No scripts in HASH.* at .*bmwqemu.pm line 181."Resolved2020-04-20

History

#1 Updated by okurz 9 months ago

  • Subject changed from incomplete with reason "died: terminated prematurely" but log shows error 404 failing to download asset into cache to incomplete with reason "died: terminated prematurely" but log shows error 404 failing to download asset into cache auto_review:"(?s)Download.*failed: 404.*No scripts"

#2 Updated by Xiaojing_liu 9 months ago

I did a test after upgrading my local openQA. After the No scripts was fixed, seems the failed reason is reasonable.
Here is my test job: http://10.67.19.103/tests/42

#3 Updated by okurz 9 months ago

  • Is duplicate of action #65840: auto_review:"No scripts in HASH.* at .*bmwqemu.pm line 181." added

#4 Updated by okurz 9 months ago

  • Status changed from Workable to Rejected
  • Assignee set to okurz

yes, this looks good. So I assume the actual fix was https://github.com/os-autoinst/openQA/pull/2960 for #65840 . Let's assume it's the resolution then :) So I will treat this as duplicate.

Also available in: Atom PDF