action #66060


Obs_rsync not working anymore

Added by dimstar_suse over 3 years ago. Updated over 3 years ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:


Since today we observe that completed Staging as well as new products triggered for test by openQA are no longer being synced / scheduled on o3

Eg. Tumbleweed snapshot 0423 should have been there for a couple hours.

Staging:D/22.1 was ready a few hours ago. Even triggering a manual sync (after clicking forget) does not make the test runs show up

Actions #1

Updated by coolo over 3 years ago

  • Assignee set to andriinikitin

There is some {openqa.cmd}.log saying {openqa.cmd} does not exist

Actions #2

Updated by coolo over 3 years ago

Running openqa.cmd manually makes it tick again

Actions #3

Updated by okurz over 3 years ago

Maybe sync scripts fail because of a bug I introduced into the client and need . I will merge the fix, make sure it gets deployed and monitor if it help.

Actions #4

Updated by andriinikitin over 3 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

4 syncs failed because I tried to hotpatch a workaround for that client bug mentioned by okurz and forgot one comma in /opt/openqa-trigger-from-obs/scripts/ (they would fail anyway after first openqa command). (All commands were generated properly, just because of the typo instead of openqa.cmd the tool tried to execute {openqa.cmd}.
The problem was resolved on 25-Apr 15:50 CET, then I manually triggered openqa commands for Factory ARM and Staging B, H, J.
Further syncs that day did execute all required commands properly. (There might be an issue with notification(?), which is not related to this problem).

Actions #5

Updated by okurz over 3 years ago

thanks for resolving this. Yes, I guess we can improve something about the notification. Would you care to create a followup ticket describing your ideas?


Also available in: Atom PDF