Project

General

Profile

action #65396

coordination #36712: [saga] Use YaST specific framework for GUI testing

coordination #50672: [funtional][y][epic] Use libyui-rest-api for YaST modules testing

[functional][y] Move YRichText and YMenuButton out of "press" action block

Added by oorlov about 1 year ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
2020-04-07
Due date:
% Done:

0%

Estimated time:

Description

Motivation

YRichText and YMenuButton both has "press" action specified in YHttpWidgetsActionHandler.

The problem is they also require 'value' to be send, though YPushButton only requires 'press' action.

Task

In order to make the actions more consistent, consider moving the YRichText and YMenuButton out of "press" action block (e.g. to "select", or consider adding another action and move them there).

History

#1 Updated by oorlov about 1 year ago

  • Category changed from Enhancement to existing tests to Infrastructure

#2 Updated by riafarov about 1 year ago

  • Due date deleted (2020-04-21)
  • Target version set to future

#3 Updated by riafarov 12 months ago

  • Status changed from New to Resolved
  • Assignee set to riafarov

Also available in: Atom PDF