Project

General

Profile

action #65067

[kernel] test fails in clone301

Added by pcervinka 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA tests - Done - kernel&network
Start date:
2020-03-31
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

Observation

openQA test in scenario sle-15-SP2-Online-x86_64-ltp_syscalls_slub_debug@64bit fails in
clone301

Test suite description

Maintainer: pvorel, rpalethorpe. Same as ltp_syscalls, but with slub_debug=FZPU. Note that only newer SUSE products use the SLUB allocator.

Reproducible

Fails since (at least) Build 143.1

Expected result

Last good: 142.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by pcervinka 5 months ago

@richie could you please check it? metan mentioned that you already had idea, thank you

#2 Updated by pcervinka 5 months ago

metan mentioned: it's likely a race between parent setting a signal handler and child calling exit(0) that sends a signal to the parent

#4 Updated by pcervinka 5 months ago

  • Status changed from New to Feedback
  • Target version changed from Planned - kernel&network to doing board - kernel

Thanks for the quick fix. Let's wait for next build.

#5 Updated by pcervinka 4 months ago

  • Status changed from Feedback to In Progress

#6 Updated by metan 4 months ago

I messed up the first fix, no wonder if still fails. I've send a new patch to the ML and this one has been tested to fix the problem.

http://lists.linux.it/pipermail/ltp/2020-April/016484.html

#7 Updated by pcervinka 4 months ago

  • Status changed from In Progress to Resolved
  • Assignee set to metan

Looks ok after latest fix.

#8 Updated by pcervinka 4 months ago

  • Target version changed from doing board - kernel to Done - kernel&network

Also available in: Atom PDF