Project

General

Profile

action #64970

[desktop][opensuse][multi-machine] test fails in xrdp_client to connect to server

Added by okurz almost 2 years ago. Updated 7 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-03-29
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-desktopapps-remote-desktop-xrdp-client1@64bit_virtio fails in
xrdp_client
trying to connect to the remote server which most likely is not even ready to accept connections at this point, e.g. showing errors as in https://openqa.opensuse.org/tests/1214144#step/windows_network_setup/3 . It looks like the test code does not ensure that we can reach the remote server when it is ready to accept actual connections.

Reproducible

This seems to fail sporadically but most likely related to the worker instances on which it is triggered on.

Expected result

Last good: 20200326 (or more recent)

Suggestions

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Infrastructure - action #64700: setup o3 workers openqaworker4 and openqaworker7 for multi-machine testsWorkable2020-03-20

History

#1 Updated by okurz almost 2 years ago

  • Related to action #64700: setup o3 workers openqaworker4 and openqaworker7 for multi-machine tests added

#2 Updated by zcjia 7 months ago

  • Status changed from Workable to Resolved

xrdp tests are working on TW right now.

Also available in: Atom PDF