Project

General

Profile

action #64896

[SLE][Migration][SLE15SP2][Regression]test fails in consoletest_finish

Added by coolgw over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-03-27
Due date:
% Done:

0%

Estimated time:
12.00 h
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP2-Regression-on-Migration-from-SLE15-SPX-to-SLE15-SP2-aarch64-online_sles15sp1_pscc_basesys-srv-desk-dev-contm-lgm-py2-tsm-wsm_all_full@aarch64 fails in
consoletest_finish

Test suite description

Reproducible

Fails since (at least) Build 105.4

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #64812: [qe-core][functional][sporadic][needs-refining] test fails in shutdown - Screen buffer shows old display state instead of locked screen, ensure_unlocked_desktop thinks it is unlocked and test fails laterNew

History

#1 Updated by coolgw over 1 year ago

Seems worker disable display during check, so rerun it firstly.
rerun it.
linux-4360:~/openqa-distr # /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 4045099 --skip-download _GROUP=0Created job #4052026: sle-15-SP2-Regression-on-Migration-from-SLE15-SPX-to-SLE15-SP2-aarch64-Build164.1-online_sles15sp1_pscc_basesys-srv-desk-dev-contm-lgm-py2-tsm-wsm_all_full@aarch64 -> http://openqa.suse.de/t4052026

#2 Updated by coolgw over 1 year ago

  • Subject changed from [SLE][Migration][SLE15SP2]test fails in consoletest_finish - needle issue or other? to [SLE][Migration][SLE15SP2]test fails in consoletest_finish

#3 Updated by coolgw over 1 year ago

try to unlock the screen
linux-4360:~/openqa-distr # /usr/local/bin/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/debug-aa http://openqa.suse.de/tests/4045099 INCLUDE_SERVICES=""
Created job #4052027: sle-15-SP2-Regression-on-Migration-from-SLE15-SPX-to-SLE15-SP2-aarch64-Build164.1-online_sles15sp1_pscc_basesys-srv-desk-dev-contm-lgm-py2-tsm-wsm_all_full@aarch64 -> http://openqa.suse.de/t4052027

#4 Updated by okurz over 1 year ago

  • Related to action #64812: [qe-core][functional][sporadic][needs-refining] test fails in shutdown - Screen buffer shows old display state instead of locked screen, ensure_unlocked_desktop thinks it is unlocked and test fails later added

#5 Updated by okurz over 1 year ago

This looks very much related to #64812 . I know it is also hard work but think it can help a lot to also track more tickets created by others. In then end a lot of issues are really common and affect more than one team.

#6 Updated by coolgw over 1 year ago

try sent some key to resume lock screen.
linux-4360:~/openqa-distr # /usr/local/bin/openqa-clone-custom-git-refspec-debug1 https://github.com/coolgw/os-autoinst-distri-opensuse/tree/debug-aa http://openqa.suse.de/tests/4045099
Created job #4052279: sle-15-SP2-Regression-on-Migration-from-SLE15-SPX-to-SLE15-SP2-aarch64-Build164.1-online_sles15sp1_pscc_basesys-srv-desk-dev-contm-lgm-py2-tsm-wsm_all_full@aarch64 -> http://openqa.suse.de/t4052279

#7 Updated by coolgw over 1 year ago

the issue is the screen into lock status,so just send key to unlock is ok. rerun it with key sent.
linux-4360:~/openqa-distr # /usr/local/bin/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/unlock-screeen http://openqa.suse.de/tests/4045099 INCLUDE_SERVICES="apache2"
Created job #4065895: sle-15-SP2-Regression-on-Migration-from-SLE15-SPX-to-SLE15-SP2-aarch64-Build164.1-online_sles15sp1_pscc_basesys-srv-desk-dev-contm-lgm-py2-tsm-wsm_all_full@aarch64 -> http://openqa.suse.de/t4065895

#9 Updated by leli over 1 year ago

  • Subject changed from [SLE][Migration][SLE15SP2]test fails in consoletest_finish to [SLE][Migration][SLE15SP2][Regression]test fails in consoletest_finish
  • Priority changed from Normal to Urgent
  • Estimated time set to 12.00 h

#10 Updated by coolgw over 1 year ago

  • Status changed from New to Blocked

latest result show maybe another issue block this issue, the test canceled but not reach max_time??
https://openqa.nue.suse.com/tests/4098362#settings

#12 Updated by leli over 1 year ago

  • Priority changed from Urgent to Normal

#13 Updated by coolgw over 1 year ago

  • Status changed from Blocked to In Progress

https://openqa.suse.de/tests/4128395#step/consoletest_finish/14 start show again, so i create new needle and rerun it.
new run start, let's see what's happen:
https://openqa.suse.de/tests/4131444#settings
block on first_boot.

#14 Updated by coolgw over 1 year ago

latest result show it still block by other issue, we need wait another run for verify this.
https://openqa.suse.de/tests/4136710#step/install_service/1

#15 Updated by coolgw over 1 year ago

  • Status changed from In Progress to Blocked

latest result still can not reach this module, i set block currently
https://openqa.suse.de/tests/4147417

#16 Updated by coolgw over 1 year ago

  • Status changed from Blocked to Resolved

if you check following resutl then you will found new needle matched and result is good now.
https://openqa.suse.de/tests/4193617#step/consoletest_finish/13

#17 Updated by hjluo over 1 year ago

Also available in: Atom PDF