Project

General

Profile

action #64710

[qac][public cloud] Failed to get credentials form Vault server for Azure-HPC-BYOS

Added by jlausuch over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-03-21
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

All the tests in Azure-HPC-BYOS fail to talk to Vault server. For other flavors it works: I have re-run tests at the same time in one flavor and the others and it always fails in Azure-HPC-BYOS flavor.

https://openqa.suse.de/tests/4020950#step/run_ltp/32

Not sure what is happening in the background, but looks like when vault_get_secrets is called, it calls vault_api and fails the 3 times it calls __vault_api.

We should increase the debug messages here, cause it's difficult to debug with only these calls:

[2020-03-21T18:26:42.592 CET] [debug] tests/publiccloud/run_ltp.pm:59 called publiccloud::basetest::provider_factory -> lib/publiccloud/basetest.pm:65 called publiccloud::azure::init -> lib/publiccloud/azure.pm:44 called publiccloud::azure::vault_create_credentials -> lib/publiccloud/azure.pm:64 called testapi::record_info
[2020-03-21T18:26:42.592 CET] [debug] <<< testapi::record_info(title="INFO", output="Get credentials from VAULT server.", result="ok")
[2020-03-21T18:27:12.732 CET] [debug] Maximum number of Vault request retries exceeded. Check Vault Server is up and running at /var/lib/openqa/cache/openqa.suse.de/tests/sle/lib/publiccloud/provider.pm line 549.
[2020-03-21T18:27:12.735 CET] [debug] lib/publiccloud/basetest.pm:94 called publiccloud::basetest::_cleanup -> lib/publiccloud/basetest.pm:80 called (eval) -> lib/publiccloud/basetest.pm:80 called run_ltp::cleanup -> tests/publiccloud/run_ltp.pm:103 called testapi::type_string    

History

#1 Updated by cfconrad over 1 year ago

The problem is, that the WORKERS_CLASS isn't pc_azure and so _SECRET_* variables are not in place.

And yeah, there is a problem with the latest change, that we just discard the die() messages and replace it with our own one. So we don't get the croak from get_required_var().

#2 Updated by cfconrad over 1 year ago

Re triggered with

openqa-clone-job --within-instance https://openqa.suse.de 4020963 WORKER_CLASS=pc_azure

#3 Updated by jlausuch over 1 year ago

Ok, I didn't dig into that detail. Good catch!

#4 Updated by jlausuch over 1 year ago

  • Target version changed from 445 to 457

#5 Updated by jlausuch over 1 year ago

  • Subject changed from [kernel][public cloud] Failed to get credentials form Vault server for Azure-HPC-BYOS to [qac][public cloud] Failed to get credentials form Vault server for Azure-HPC-BYOS
  • Target version deleted (457)

#6 Updated by cfconrad over 1 year ago

  • Status changed from Workable to Resolved

Also available in: Atom PDF