Project

General

Profile

action #64664

[sle][migration][backlog] Test fails in reconnect_mgmt_console - Test died: Bizarre copy of ARRAY in list assignment at /usr/lib/perl5/vendor_perl/5.26.1/Devel/StackTrace.pm line 61

Added by hjluo over 2 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-03-20
Due date:
% Done:

0%

Estimated time:
12.00 h
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP2-Migration-from-SLE12-SP5-to-SLE15-SP2-s390x-offline_sles12sp5_pscc_asmm-lgm_all_full@s390x-kvm-sle15 fails in
reconnect_mgmt_console

Test suite description

Reproducible

Fails since (at least) Build 89.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #56741: [SLE][Migration][backlog] test fails in reconnect_mgmt_console: Error connecting to VNC server timeout or auto_review:"(Bizarre copy of (HASH|ARRAY) in list assignment|attempt to copy freed scalar)"Blocked2019-09-10

History

#1 Updated by hjluo over 2 years ago

It's failed in reconnect_mgmt_console.
Test died: Bizarre copy of ARRAY in list assignment at /usr/lib/perl5/vendor_perl/5.26.1/Devel/StackTrace.pm line 61.

openQA test in scenario sle-15-SP2-Migration-from-SLE12-SP5-to-SLE15-SP2-s390x-offline_sles12sp5_pscc_asmm-lgm_all_full@s390x-kvm-sle15 fails in
[reconnect_mgmt_console]

#2 Updated by hjluo over 2 years ago

  • Subject changed from [SLE][Migration][SLE15SP2] test fails in reconnect_mgmt_console - Test died: Bizarre copy of ARRAY in list assignment at /usr/lib/perl5/vendor_perl/5.26.1/Devel/StackTrace.pm line 61 to [SLE][tools][SLE15SP2] test fails in reconnect_mgmt_console - Test died: Bizarre copy of ARRAY in list assignment at /usr/lib/perl5/vendor_perl/5.26.1/Devel/StackTrace.pm line 61

It's failed in reconnect_mgmt_console.
Test died: Bizarre copy of ARRAY in list assignment at /usr/lib/perl5/vendor_perl/5.26.1/Devel/StackTrace.pm line 61.

openQA test in scenario sle-15-SP2-Migration-from-SLE12-SP5-to-SLE15-SP2-s390x-offline_sles12sp5_pscc_asmm-lgm_all_full@s390x-kvm-sle15 fails
in [reconnect_mgmt_console]

#3 Updated by hjluo over 2 years ago

  • Subject changed from [SLE][tools][SLE15SP2] test fails in reconnect_mgmt_console - Test died: Bizarre copy of ARRAY in list assignment at /usr/lib/perl5/vendor_perl/5.26.1/Devel/StackTrace.pm line 61 to [tools]est fails in reconnect_mgmt_console - Test died: Bizarre copy of ARRAY in list assignment at /usr/lib/perl5/vendor_perl/5.26.1/Devel/StackTrace.pm line 61

#4 Updated by hjluo over 2 years ago

  • Subject changed from [tools]est fails in reconnect_mgmt_console - Test died: Bizarre copy of ARRAY in list assignment at /usr/lib/perl5/vendor_perl/5.26.1/Devel/StackTrace.pm line 61 to [tools] Test fails in reconnect_mgmt_console - Test died: Bizarre copy of ARRAY in list assignment at /usr/lib/perl5/vendor_perl/5.26.1/Devel/StackTrace.pm line 61

#5 Updated by hjluo over 2 years ago

current the error is
Test died: panic: attempt to copy freed scalar 564dcabff358 to 564dcd9fceb8 at /usr/lib/perl5/vendor_perl/5.26.1/Devel/StackTrace.pm line 61.in https://openqa.nue.suse.com/tests/3995955#step/reconnect_mgmt_console/13

#6 Updated by okurz over 2 years ago

  • Subject changed from [tools] Test fails in reconnect_mgmt_console - Test died: Bizarre copy of ARRAY in list assignment at /usr/lib/perl5/vendor_perl/5.26.1/Devel/StackTrace.pm line 61 to [migration] Test fails in reconnect_mgmt_console - Test died: Bizarre copy of ARRAY in list assignment at /usr/lib/perl5/vendor_perl/5.26.1/Devel/StackTrace.pm line 61

I assume by adding the "[tools]" tag you expect members from the "tools" team to take a look which … worked :) coolo and me have shortly looked into this error but do not have a good idea. "Devel::StackTrace" is not a package that is directly imported nor used by os-autoinst or os-autoinst-distri-opensuse. The problem is so far only known to appear in either just this single scenario or just in s390x-kvm migration scenarios and nowhere else AFAIK. I am afraid we are no better help to solving this issue, the necessary tasks to resolve would be the same for you as well as us. I suggest you narrow down the problem, try to reproduce it with the least amount of test modules or test code as possible, try to find a "last good", compare what has changed since then, etc.

#7 Updated by hjluo over 2 years ago

  • Subject changed from [migration] Test fails in reconnect_mgmt_console - Test died: Bizarre copy of ARRAY in list assignment at /usr/lib/perl5/vendor_perl/5.26.1/Devel/StackTrace.pm line 61 to [sle][migration][backlog] Test fails in reconnect_mgmt_console - Test died: Bizarre copy of ARRAY in list assignment at /usr/lib/perl5/vendor_perl/5.26.1/Devel/StackTrace.pm line 61

ok, we'll move this ticket to our backlog and will track it once we find a last good case and then discuss with tool guys. stay tuned.

#8 Updated by leli over 2 years ago

  • Assignee set to hjluo
  • Priority changed from Normal to High
  • Estimated time set to 12.00 h

#9 Updated by coolgw over 2 years ago

  • Related to action #56741: [SLE][Migration][backlog] test fails in reconnect_mgmt_console: Error connecting to VNC server timeout or auto_review:"(Bizarre copy of (HASH|ARRAY) in list assignment|attempt to copy freed scalar)" added

#10 Updated by coolgw over 2 years ago

  • Status changed from New to Rejected

same error as Related to action #56741: [SLE][Migration][backlog] test fails in reconnect_mgmt_console: Error connecting to VNC server timeout added

Also available in: Atom PDF