Project

General

Profile

action #63361

[desktop][sporadic] test fails in xrdp_client trying to generate a remmina config

Added by okurz 9 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-02-10
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-desktopapps-remote-desktop-xrdp-client1@64bit_virtio fails in
xrdp_client trying to generate a remmina config

Test suite description

The base test suite is used for job templates defined in YAML documents. It has no settings of its own.

Reproducible

Fails since (at least) Build 20200209 (current job)

Expected result

Last good: 20200207 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by StefanBruens 9 months ago

Looking at serial0.txt, its quite obvious what happens:

fJYzc
[  346.005211] PackageKit[2262]: daemon quit
1581370037
SCRIPT_FINISHEDfJYzc-0-

i.e. both the 'date +%s' output and a kernel message end up in the assert_script_run output.

Is this a bug in assert_script_run, or should the output be filtered? e.g. '$timestamp =~ s/.(\d{10})./\1/gm;'

#2 Updated by okurz 9 months ago

  • Status changed from New to In Progress
  • Assignee changed from yfjiang to okurz

problem is script_output used wrong in

my $timestamp = script_output('date "+%s"', type_command => 1);
assert_script_run "mkdir $pref_dir";
assert_script_run "echo -e \'[remmina_news]\\nperiodic_rmnews_last_get='$timestamp'\' >> '$pref_dir'/remmina.pref";

as http://open.qa/api/testapi/#_script_output describes "NOTE: execution result may include extra serial output which was on serial console since command was triggered in case serial console is not dedicated for the script output only."

Instead of the above code I simply recommend

assert_script_run "mkdir $pref_dir";
assert_script_run 'echo -e "[remmina_news]\\nperiodic_rmnews_last_get=$(date +%s)" >> ' . $pref_dir . '/remmina.pref';

I will try this myself -> https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/9541

#3 Updated by okurz 9 months ago

  • Status changed from In Progress to Resolved

merged, https://openqa.opensuse.org/tests/1170427 shows successful tests on o3

Also available in: Atom PDF