Project

General

Profile

action #63205

[functional][y] test fails in scc_registration - Downloading package window shown (Slow network)

Added by szarate over 1 year ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Low
Assignee:
Category:
Enhancement to existing tests
Target version:
Start date:
2020-02-06
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP2-Online-aarch64-pcm_azure@aarch64 fails in
scc_registration

Looking at the y2log, looks like the package was downloaded succesfully, however, it took a bit too long (heavy network usage?). Perhaps creating a new needle that waits a bit if this is shown? could help with the problem?. It might be hiding a yast bug.

2020-02-05 22:04:48 <0> install(3318) [Ruby] binary/Yast.cc(ycp_module_call_ycp_function):332 Append parameter "Downloading: http://openqa.suse.de/.../skelcd-control-SLES-15.2.1-1.9.aarch64.rpm - 16.9 KiB/s (on average 16.9 KiB/s)"
...
2020-02-05 22:04:48 <1> install(3318) [zypp++] MediaMultiCurl.cc(doGetFileCopy):1373 HTTP response: 200
2020-02-05 22:04:48 <1> install(3318) [zypp++] MediaMultiCurl.cc(looks_like_metalink):1240 looks_like_metalink(/var/adm/mount/AP_0x8z5oxF/aarch64/skelcd-control-SLES-15.2.1-1.9.aarch64.rpm.new.zypp.QzM8nS): 0
2020-02-05 22:04:48 <1> install(3318) [zypp] PathInfo.cc(rename):701 rename /var/adm/mount/AP_0x8z5oxF/aarch64/skelcd-control-SLES-15.2.1-1.9.aarch64.rpm.new.zypp.QzM8nS -> /var/adm/mount/AP_0x8z5oxF/aarch64/skelcd-control-SLES-15.2.1-1.9.aarch64.rpm
2020-02-05 22:04:48 <1> install(3318) [zypp++] MediaMultiCurl.cc(doGetFileCopy):1493 done: /var/adm/mount/AP_0x8z5oxF/aarch64/skelcd-control-SLES-15.2.1-1.9.aarch64.rpm{- 0644 0/0 size 17256}
2020-02-05 22:04:48 <0> install(3318) [Pkg] Callbacks.YCP.cc(evaluate):240 Evaluating callback (registered funciton: ruby_reference)
2020-02-05 22:04:48 <1> install(3318) [Ruby] modules/PackageCallbacks.rb:1833 Download finished
2020-02-05 22:04:48 <1> install(3318) [zypp++] MediaHandler.cc(provideFile):1015 provideFile(./aarch64/skelcd-control-SLES-15.2.1-1.9.aarch64.rpm)
2020-02-05 22:04:48 <1> install(3318) [zypp++] MediaManager.cc(checkDesired):98 checkDesired(34): desired (cached)
2020-02-05 22:04:48 <1> install(3318) [zypp:fetcher] Fetcher.cc(validate):366 Checking job [/var/adm/mount/AP_0x8z5oxF/aarch64/skelcd-control-SLES-15.2.1-1.9.aarch64.rpm] (2 checkers )
2020-02-05 22:04:48 <1> install(3318) [zypp] PathInfo.cc(assert_dir):354 mkdir /var/cache/zypp/packages/SUSE_Linux_Enterprise_Server_15_SP2_aarch64:SLE-Product-SLES15-SP2-Pool/aarch64 00755
2020-02-05 22:04:48 <1> install(3318) [zypp] PathInfo.cc(hardlinkCopy):869 hardlinkCopy /var/adm/mount/AP_0x8z5oxF/aarch64/skelcd-control-SLES-15.2.1-1.9.aarch64.rpm -> /var/cache/zypp/packages/SUSE_Linux_Enterprise_Server_15_SP2_aarch64:SLE-Product-SLES15-SP2-Pool/aarch64/skelcd-control-SLES-15.2.1-1.9.aarch64.rpm
2020-02-05 22:04:48 <1> install(3318) [zypp++] MediaSetAccess.cc(releaseFile):88 Going to release file ./aarch64/skelcd-control-SLES-15.2.1-1.9.aarch64.rpm from media number 1
2020-02-05 22:04:48 <1> install(3318) [zypp] PathInfo.cc(unlink):659 unlink /var/adm/mount/AP_0x8z5oxF/aarch64/skelcd-control-SLES-15.2.1-1.9.aarch64.rpm
2020-02-05 22:04:48 <1> install(3318) [Progress++] ProgressData.cc(report):88 {#221|}END

Test suite description

Maintainer: jrivera. Perform installation with Public Cloud Module enabled and Microsoft Azure pattern(s) enabled without publishing any image.

Reproducible

Fails since (at least) Build 136.2 (current job)

Expected result

Last good: 136.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by riafarov over 1 year ago

  • Priority changed from Normal to Low
  • Target version set to future

We have tons of issues like this, we can only inject workaround to wait longer. As we don't see this particular on in YaST job group, feel free to move to qsf-u backlog.

#2 Updated by riafarov about 1 year ago

  • Status changed from New to Rejected
  • Assignee set to riafarov

rejecting as seems not to occur anymore. Feel free to reopen in case you believe there is something workable here.

Also available in: Atom PDF