Project

General

Profile

Actions

action #61832

closed

[functional][y] autoyast: re-enable yast2_firstboot test in TW once typing issue is resolved

Added by dimstar over 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 32
Start date:
2020-01-07
Due date:
2020-05-19
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-yast2_firstboot@64bit fails in
yast2_firstboot

We seem to 'just' miss the timeout - after the 'failed' screen, the correct screen with keyboard/language is being shown.

Test suite description

Smoke test for YaST2 Firstboot module, boot an existing image, enable YaST2 Firstboot after successful login to the SUT and reboot again. SUT should boot to YaST2 Firstboot wizard, go through all Firstboot tabs, configure root and user accounts. SUT should end up in GDM screen after exiting YaST2 Firstboot.

Reproducible

Fails since (at least) Build 20190731

Expected result

Last good: 20190730 (or more recent)

Further details

Always latest result in this scenario: latest

Actions #2

Updated by dimstar over 4 years ago

dimstar wrote:

Proposal: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/9251

Seems this is only the tip of the iceberg - the keybaord/lang screen now shows up, but we seem to have trouble pressing 'alt-n' for 'next' :(

Actions #3

Updated by riafarov over 4 years ago

  • Subject changed from autoyast: test fails in yast2_firstboot to [functional][y] autoyast: test fails in yast2_firstboot
  • Due date set to 2020-01-28
  • Target version set to Milestone 32
Actions #4

Updated by riafarov about 4 years ago

  • Due date changed from 2020-01-28 to 2020-02-11
Actions #5

Updated by riafarov about 4 years ago

dimstar wrote:

dimstar wrote:

Proposal: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/9251

Seems this is only the tip of the iceberg - the keybaord/lang screen now shows up, but we seem to have trouble pressing 'alt-n' for 'next' :(

Right, that was the problem we had before. I would propose to move these first boot scenarios to development job group for now, not to pollute test results and try ti apply some workaround.
Weird thing is that for SLES this test work just fine.

Actions #6

Updated by riafarov about 4 years ago

  • Due date changed from 2020-02-11 to 2020-02-25

So as previous comments, we are back to the issue with typing. We will consider applying workarounds. As of now I will move those to the development job group.

Actions #7

Updated by riafarov about 4 years ago

  • Subject changed from [functional][y] autoyast: test fails in yast2_firstboot to [functional][y] autoyast: re-enable yast2_firstboot test in TW once typing issue is resolved
  • Due date deleted (2020-02-25)
  • Status changed from New to Blocked
  • Assignee set to riafarov
Actions #8

Updated by riafarov about 4 years ago

  • Blocked by action #50399: [functional][y] Installer doesn't react to key press added
Actions #9

Updated by riafarov almost 4 years ago

  • Due date set to 2020-05-19
  • Status changed from Blocked to New
  • Assignee deleted (riafarov)

Test suite works fine for 2 weeks, so we can re-enable it the main job group.

Actions #10

Updated by riafarov almost 4 years ago

  • Status changed from New to Feedback
  • Assignee set to riafarov

Re-enabled, waiting for the next build to see that it worked fine.

Actions #11

Updated by riafarov almost 4 years ago

  • Blocked by deleted (action #50399: [functional][y] Installer doesn't react to key press)
Actions #12

Updated by riafarov almost 4 years ago

  • Status changed from Feedback to Resolved
Actions #13

Updated by riafarov almost 4 years ago

Test fails due to cracklib issue now, typing works fine as we have changed username to different one.

Actions

Also available in: Atom PDF