Project

General

Profile

action #60821

test fails in regproxy (missing python3-requests)

Added by dimstar over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-12-09
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario microos-Tumbleweed-Kubic-DVD-x86_64-kubeadm@64bit-2G-HD40G fails in
regproxy

regproxy imports requests, and relies on this being present on the installed system. So far this was true, but ceph-common changed its deps and dropped the -requests dependency.

This now results in regproxy failing to launch:

Dec 09 14:26:03 linux-2fjw systemd[1]: Started Registry proxy.
Dec 09 14:26:03 linux-2fjw python3[2279]: Traceback (most recent call last):
Dec 09 14:26:03 linux-2fjw python3[2279]:   File "regproxy.py", line 6, in <module>
Dec 09 14:26:03 linux-2fjw python3[2279]:     import requests
Dec 09 14:26:03 linux-2fjw python3[2279]: ModuleNotFoundError: No module named 'requests'
Dec 09 14:26:03 linux-2fjw systemd[1]: regproxy.service: Main process exited, code=exited, status=1/FAILURE
Dec 09 14:26:03 linux-2fjw systemd[1]: regproxy.service: Failed with result 'exit-code'.

Test suite description

Reproducible

Fails since (at least) Build 20191207

Expected result

Last good: 20191206 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by fos over 1 year ago

Fixed in https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/9110 by replacing the requests module (which is not pulled in by other packages any more) with generic http.client code.

#2 Updated by RBrownSUSE over 1 year ago

  • Status changed from New to Resolved

Also available in: Atom PDF