Project

General

Profile

action #60782

openQA Tests - action #15132: [saga][epic] Better structure of test plans in main.pm

action #44360: [epic] Parameterize test suites within job groups

action #55730: [epic] Move parameters from test suites into job groups

descriptions for parameterized job templates independant of test suite descriptions

Added by okurz 7 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
Start date:
2019-12-06
Due date:
% Done:

100%

Estimated time:
Difficulty:
Duration:

Description

Motivation

We finished the main part for #59097 so https://openqa.opensuse.org/tests/overview?groupid=24 looks nice, see the second test named openqa_from_git_in_place_defined_testsuite_poo55730" which merely inherits an "empty" test suite. The next requirement I see so that we can get rid of the actual test suite definitions is that we do not want the description to vanish. We should have a description for job templates overwriting test suite descriptions if any.

Acceptance criteria

  • AC1: A description can be specified for parameterized job templates in the job group yaml documents
  • AC2: The description from parameterized job templates is shown on job details page instead of the one from a test suite
  • AC3: Same as AC2 but for /tests/overview

Suggestions

  • Add a column "description" to job templates table
  • Allow to add key "description" to every job template in yaml format
  • If description exists on job template display that, else fallback to testsuite description
  • Ensure the same description is still shown for machine variants on /tests/overview, same as for testsuites, e.g. for a job template "foo" the description should be shown for the /tests/overview entry "foo@spvm" just as well

History

#1 Updated by okurz 7 months ago

  • Description updated (diff)

#2 Updated by tinita 7 months ago

  • Status changed from New to In Progress
  • Assignee set to tinita

#3 Updated by tinita 7 months ago

  • Target version set to Current Sprint

#4 Updated by tinita 7 months ago

  • % Done changed from 0 to 20

I created two PRs

https://github.com/os-autoinst/openQA/pull/2590 - Fix regex and error message for prio (merged)

https://github.com/os-autoinst/openQA/pull/2596 - Refactor JobTemplates and fix regex substitution
In the second I did some refactoring which will make testing easier in the future.

Now working on the actual feature in branch job-template-descr in my fork.
Basically the features work, but needs cleanup and more tests.

#5 Updated by okurz 7 months ago

PR is merged.

I added a description key in https://openqa.opensuse.org/admin/job_templates/24 but https://openqa.opensuse.org/tests/overview?distri=openqa&version=Tumbleweed&build=%3ATW.3716&groupid=24 does not show it.

Further suggestions to follow on as next step:

#7 Updated by tinita 6 months ago

Created PR for the following points: https://github.com/os-autoinst/openQA/pull/2633

#8 Updated by tinita 6 months ago

I'm working on adding the test suite description to the Job Settings.
So far t/ui/10-tests_overview.t is failing. There are some adaptions necessary in t/fixtures/01-jobs.pl, but I haven't got it working yet.

We should be aware that adding the description to the settings will make it a fixed string, while loading it from the test suites table will always fetch the current description.
If that's what we want then it is probably the way to go.

OTOH, saving a copy of something to another table just to save SQL statements can also be a sign that we want caching (e.g. Redis or memcached). Some job information never changes and could probably cached, and as soon as the build is done, everything could be cached. Loading a page like https://openqa.opensuse.org/tests/overview?distri=opensuse&version=15.2&build=547.2&groupid=50 is quite slow, as it is doing several SQL statements for each of the jobs.

#9 Updated by okurz 6 months ago

tinita wrote:

okurz I can see the desciption here: https://openqa.opensuse.org/tests/overview?distri=openqa&version=Tumbleweed&build=%3ATW.3750&groupid=24

yes, I can confirm. Hm, seems to be good then :)

#10 Updated by tinita 6 months ago

PR https://github.com/os-autoinst/openQA/pull/2642 Rename TEST_SUITE_DESCRIPTION to JOB_DESCRIPTION
was merged

#11 Updated by tinita 6 months ago

  • Status changed from In Progress to Feedback
  • % Done changed from 20 to 100

#12 Updated by okurz 6 months ago

do you consider this sufficient to close the ticket as "Resolved" or plan more work?

#13 Updated by tinita 6 months ago

  • Status changed from Feedback to Resolved

No, I don't plan more work

Also available in: Atom PDF