Project

General

Profile

action #60725

[kernel]Can't use an undefined value as a symbol reference at /usr/lib/os-autoinst/consoles/serial_screen.pm line 106.

Added by cfconrad almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-12-05
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP5-Server-DVD-Incidents-Kernel-s390x-ltp_syscalls@s390x-kvm-sle12 fails in
boot_ltp

Test suite description

A large collection of tests for individual system calls. This is generally considered to be the most important test suit within the LTP.

The IPC tests have been filtered out from the syscalls runtest file. They are ran as part of the syscalls_ipc test case.

Reproducible

Fails since (at least) Build :13400:kernel-ec2 (current job)

Expected result

Last good: 4.12.14-142.1.g6e7819a (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #55883: known_issue:"Can.t fcntl" [kernel] Investigate qemu left over, when switching from unix-domain sockets to named-pipes used for virtio_console handlingResolved2019-08-23

Related to openQA Project - action #60416: "(undefined value as a symbol reference.*serial_screen|svirt serial: unable to read)" Better feedback for "The console .* is not responding (half-open socket?)", very big log files with repetition of log messageResolved2019-11-28

History

#1 Updated by cfconrad almost 3 years ago

From autoinst-log.txt

[2019-12-04T13:40:28.465 CET] [debug] <<< consoles::serial_screen::type_string(text='
', json_cmd_token='bjYlPJkG', cmd='backend_type_string')
[2019-12-04T13:40:28.466 CET] [debug] Backend process died, backend errors are reported below in the following lines:
Can't use an undefined value as a symbol reference at /usr/lib/os-autoinst/consoles/serial_screen.pm line 106.

Issue was introduced with https://github.com/os-autoinst/os-autoinst/pull/1274. Looks like I forgot on rebase to update ssh_serial.pm which was introduced in https://github.com/os-autoinst/os-autoinst/pull/1176.

This PR https://github.com/os-autoinst/os-autoinst/pull/1313 should fix it.

If someone knows a better way to call super class constructor, plz let me know.

#2 Updated by cfconrad almost 3 years ago

  • Related to action #55883: known_issue:"Can.t fcntl" [kernel] Investigate qemu left over, when switching from unix-domain sockets to named-pipes used for virtio_console handling added

#3 Updated by cfconrad almost 3 years ago

  • Related to action #60416: "(undefined value as a symbol reference.*serial_screen|svirt serial: unable to read)" Better feedback for "The console .* is not responding (half-open socket?)", very big log files with repetition of log message added

#4 Updated by cfconrad almost 3 years ago

  • Status changed from New to Feedback

#5 Updated by maritawerner almost 3 years ago

  • Subject changed from Can't use an undefined value as a symbol reference at /usr/lib/os-autoinst/consoles/serial_screen.pm line 106. to [kernel]Can't use an undefined value as a symbol reference at /usr/lib/os-autoinst/consoles/serial_screen.pm line 106.

#6 Updated by cfconrad almost 3 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF