Project

General

Profile

action #60332

[desktop][sle15sp2] test fails in first_boot

Added by zcjia about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-11-27
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

When we first time login, gnome-software pops up polkit window for authentication, this is a product bug, but we want to workaround this ASAP for the staging tests.

I propose following workaround:

After handle_login, we do a ensure_unlocked_desktop. This should not cause problems for normal installations.

For our problem, ensure_unlocked_desktop contains code to deal with tag authentication-required-user-settings.

openQA test in scenario sle-15-SP2-Online-C-Staging-x86_64-gnome@64bit fails in
first_boot

Test suite description

Maintainer: okurz

The standard scenario where we mainly just follow installation suggestions without any adjustments as long as the default desktop is gnome.

Reproducible

Fails since (at least) Build C.104.1

Expected result

Last good: C.101.1 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #60335: [desktop][sle15sp2] test fails in reboot_gnomeResolved2019-11-27

History

#2 Updated by okurz about 2 years ago

  • Status changed from New to In Progress
  • Assignee set to okurz

I was asked by yfjiang to support

#3 Updated by okurz about 2 years ago

  • Related to action #60335: [desktop][sle15sp2] test fails in reboot_gnome added

#5 Updated by okurz about 2 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF