action #60278

circleci fails on personal fork when branch "gh-pages" does not exist

Added by okurz 4 months ago. Updated 4 months ago.

Status:ResolvedStart date:26/11/2019
Priority:LowDue date:
Assignee:andriinikitin% Done:

100%

Category:Concrete Bugs
Target version:Current Sprint
Difficulty:easy
Duration:

Description

Observation

Seems like the circleci job "build-docs" fails when the branch "gh-pages" does not exist, e.g. in personal forks, e.g. as in https://app.circleci.com/jobs/github/okurz/openQA/4 where I do not see the need to test anything related to "gh-pages" when.

Suggestion

Maybe we should just trigger the job "build-docs" on the branch gh-pages or when it exists?

History

#1 Updated by andriinikitin 4 months ago

  • Status changed from New to In Progress
  • Assignee set to andriinikitin
  • Target version set to Current Sprint
  • Difficulty set to easy

#2 Updated by andriinikitin 4 months ago

Just a note that this problem existed in travis days as well.
I will just let the script do nothing if the branch doesn't exists.

#3 Updated by andriinikitin 4 months ago

okurz wrote:

Maybe we should just trigger the job "build-docs" on the branch gh-pages or when it exists?

The problem is that the job must be triggered on every branch and then must work with gh-pages. And I don't think CI is smart enough to provide such filter.

So the script will just finish if it cannot proceed and let the job finish.

#5 Updated by okurz 4 months ago

PR had been merged 8 days ago. Unless you want to do more for it I suggest to resolve this ticket.

#6 Updated by andriinikitin 4 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF