Project

General

Profile

action #60167

"Download .* failed with: 521 - Connect timeout" jobs incomplete trying to download from cache, potentially worker specific

Added by okurz almost 2 years ago. Updated almost 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
-
Start date:
2019-11-22
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

https://openqa.suse.de/tests/3618352/file/autoinst-log.txt shows

[2019-11-21T15:03:24.0740 UTC] [debug] [pid:9969] Download of SLE-15-SP2-Online-aarch64-Build92.1-Media1.iso processed: [INFO] Downloading SLE-15-SP2-Online-aarch64-Build92.1-Media1.iso from openqa.suse.de/tests/3618352/asset/iso/SLE-15-SP2-Online-aarch64-Build92.1-Media1.iso
[DEBUG] CACHE: Download of /var/lib/openqa/cache/openqa.suse.de/SLE-15-SP2-Online-aarch64-Build92.1-Media1.iso failed with: 521 - Connect timeout
[DEBUG] CACHE: requested to remove nonexisting asset /var/lib/openqa/cache/openqa.suse.de/SLE-15-SP2-Online-aarch64-Build92.1-Media1.iso

Workaround

Retriggering seems to help


Related issues

Is duplicate of openQA Project - action #55529: job incompletes when it can not reach the openqa webui host just for a single time aka. retry on 521 connect timeout in cacheResolved2019-08-14

History

#1 Updated by okurz almost 2 years ago

  • Is duplicate of action #55529: job incompletes when it can not reach the openqa webui host just for a single time aka. retry on 521 connect timeout in cache added

#2 Updated by okurz almost 2 years ago

  • Status changed from New to Rejected
  • Assignee set to okurz

we try to solve this now in #55529 with a retry on these operations. I guess we consider this a duplicate.

Also available in: Atom PDF