Project

General

Profile

action #58010

Cannot mix placeholder styles \\\"\$1\\\" and \\\"?\\\" at /usr/lib/perl5\\/vendor_perl/5.26.1/x86_64-linux-thread-multi/DBD/Pg.pm line 277

Added by JRivrain 9 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Support
Target version:
Start date:
2019-10-11
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

If I try to queue a lot of clone jobs on my workstation in this manner "for i in {0..100}; do clone_job..." then it sometimes works, but most of the time drops this error:
downloading
http://localhost/tests/6588/asset/iso/SLE-15-SP2-Installer-DVD-x86_64-Build58.1-Media1.iso
to
/var/lib/openqa/factory/iso/SLE-15-SP2-Installer-DVD-x86_64-Build58.1-Media1.iso
Failed to create job: "{\"error\":\"Cannot mix placeholder styles \\"\$1\\" and \\"?\\" at \/usr\/lib\/perl5\/vendor_perl\/5.26.1\/x86_64-linux-thread-multi\/DBD\/Pg.pm line 277.\n\",\"error_status\":400,\"id\":7152}" at /usr/share/openqa/script/clone_job.pl line 360.

rpm -q openQA openQA-bootstrap openQA-client openQA-common openQA-local-db openQA-worker
openQA-4.6.1570716658.ebe3678aa-lp151.1898.1.noarch
openQA-bootstrap-4.6.1570716658.ebe3678aa-lp151.1898.1.noarch
openQA-client-4.6.1570716658.ebe3678aa-lp151.1898.1.noarch
openQA-common-4.6.1570716658.ebe3678aa-lp151.1898.1.noarch
openQA-local-db-4.6.1570716658.ebe3678aa-lp151.1898.1.noarch
openQA-worker-4.6.1570716658.ebe3678aa-lp151.1898.1.noarch

History

#1 Updated by okurz 9 months ago

  • Project changed from openQA Infrastructure to openQA Project
  • Category set to Support
  • Status changed from New to Feedback
  • Assignee set to okurz
  • Target version set to Current Sprint

This is most likely a problem with the version of the dependencies of openQA. Make sure to have version at least 3.7.4 of perl-DBD-Pg. I assume you are using openSUSE Tumbleweed or openSUSE Leap. For Tumbleweed that package should come from the main Tumbleweed repo, for Leap perl-DBD-Pg should come from devel:openQA:Leap:$version

#2 Updated by JRivrain 9 months ago

You're right, thank you! I had an older version from Leap's main repo. Shouldn't the latest openqa explicitly depend on perl-DBD-Pg > 3.7.3 then ?

#3 Updated by okurz 9 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF