Project

General

Profile

action #57719

Use of uninitialized value in numeric ne (!=) at /usr/lib/os-autoinst/OpenQA/Qemu/DriveDevice.pm line 124.

Added by okurz 9 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2019-10-04
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

Observation

Seen in https://openqa.opensuse.org/tests/1045173/file/autoinst-log.txt , probably in many more tests as well

History

#1 Updated by tinita 8 months ago

  • Status changed from New to In Progress
  • Assignee set to tinita
  • Target version set to Current Sprint

The cause of this is OpenQA::Qemu::BlockDevConf::add_iso_drive()

The other methods add_existing_drive() and add_new_drive() call:

return $self->_push_new_drive_dev($id, $overlay, $model, $num_queues);

But add_iso_drive() calls:

return $self->_push_new_drive_dev($id, $overlay, $model);

Not sure if this is an error, or if we should just fix that comparison, but since the code is working, I'll do the latter.

#3 Updated by cdywan 8 months ago

  • Status changed from In Progress to Feedback

#4 Updated by tinita 8 months ago

PR was merged

#5 Updated by okurz 8 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF