Project

General

Profile

action #57497

[kernel][xfstests] HDD size more less than setting in HDDSIZEGB

Added by lansuse almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-09-29
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

SLE12SP5 build 341:
https://openqa.suse.de/tests/3419114#step/partition/10

In settings, HDDSIZEGB = 82
but /dev/vda only 42950MB

Compare with SLE12SP5 build 339:
https://openqa.suse.de/tests/3414510#step/partition/10

In settings, HDDSIZEGB = 82
/dev/vda = 107374MB

History

#1 Updated by okurz almost 2 years ago

  • Project changed from openQA Project to openQA Tests
  • Subject changed from HDD size more less than setting in HDDSIZEGB to [kernel] HDD size more less than setting in HDDSIZEGB
  • Category set to Bugs in existing tests

I don't think there is anything wrong from "openQA" side. Compare the partitioning screen in the image creating job:

https://openqa.suse.de/tests/3414359#step/partitioning/1 and https://openqa.suse.de/tests/3418911#step/partitioning/1 look exactly the same to me so the problem is most certainly in the module "tests/xfstests/partition.pm" itself.

#2 Updated by yosun almost 2 years ago

  • Subject changed from [kernel] HDD size more less than setting in HDDSIZEGB to [kernel][xfstests] HDD size more less than setting in HDDSIZEGB
  • Priority changed from Normal to High

@Oli, thank you for look into. We will double check the root cause.

Hi @Long, I got the difference between two of your links.
The first one the root filesystem is ext4 https://openqa.suse.de/tests/3419114#step/partition/10
The second one the root filesystem is btrfs https://openqa.suse.de/tests/3414510#step/partition/10

And I found any btrfs tests after that time in xfstests is change root to ext4! Could you please check why it turns to this. I guess maybe a setting problem after your PR about btrfs-progs test with ext4 root.
Ext4 root should only enable in 1 test case in btrfs-progs, it couldn't enable in xfstests.

#3 Updated by yosun almost 2 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

I found why.
The test create_hdd_minimal_base+sdk_withhome_ext4_btrfs(which include PARTITION_EDIT=ext4_btrfs) use the same PUBLISH_HDD_1 with create_hdd_minimal_base+sdk_withhome which xfstests will use. So all xfstests turns to use ext4 root base...
I change the PUBLISH_HDD_1 of create_hdd_minimal_base+sdk_withhome_ext4_btrfs to another name, and change the HDD_1 of btrfs_progs-misc to that new HDD. (you used the HDD_1 as same as xfstest, so everything changes). Please beware next time you create new HDD you need change in both side, and create a new name with new settings.

Also available in: Atom PDF