Project

General

Profile

action #57008

[functional][u] test fails in docker - die 'Sleep schould be still running so ctrl-c stopped container'

Added by mlin7442 almost 3 years ago. Updated almost 3 years ago.

Status:
Rejected
Priority:
High
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 28
Start date:
2019-09-18
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

This looks not like product bug, but looks rather ctrl-c does not sent properly? and '#' also not there.

The string didn't reach the serial terminal when wait_serial was executed, it was there after entering the post_fail_hook. How could wait_serial success and fulfill the if statement?

Acceptance criteria

  • AC1: docker.pm uses a console that doesn't get kernel messages
  • AC2: docker.pm doesn't fail

Reproducible

  • In scenario opensuse-Tumbleweed-DVD-x86_64-docker_image@64bit
  • Fails since Build 20190916
  • Current occurrence: Build-20190921

Expected result

Last good: 20190913

Further details

Always latest result in this scenario: latest

History

#1 Updated by SLindoMansilla almost 3 years ago

  • Subject changed from test fails in docker - die 'Sleep schould be still running so ctrl-c stopped container' to [functional][u] test fails in docker - die 'Sleep schould be still running so ctrl-c stopped container'
  • Description updated (diff)
  • Priority changed from Normal to High

#3 Updated by SLindoMansilla almost 3 years ago

  • Status changed from New to Rejected

#4 Updated by SLindoMansilla almost 3 years ago

  • Assignee set to SLindoMansilla
  • Target version set to Milestone 28

Also available in: Atom PDF