Project

General

Profile

action #55166

[spvm][ppc][serial] test fails in kdump_and_crash - no response from serial

Added by pcervinka about 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
QE Kernel - QE Kernel Done
Start date:
2019-08-07
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP5-Server-DVD-ppc64le-fadump@ppc64le-spvm fails in
kdump_and_crash

Test suite description

Maintainer: pcervinka, installation and fadump test on spvm backend

Reproducible

Fails since (at least) Build 0248

Expected result

Last good: 0242 (or more recent)

Further details

Always latest result in this scenario: latest

Test fails on timeout during package installation, but zypper command is fine and there is missing "check" string on serial.

# wait_serial expected: qr/(?^:2vdJ6-\d+-)/

History

#1 Updated by pcervinka about 2 years ago

Issue found on line: https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/2a4ce0dd7485a9f1bcabe1ef6870c5d8434a3126/lib/susedistribution.pm#L685

    elsif ($console =~ m/root-console$/ && get_var('BACKEND' =~ /ikvm|ipmi|spvm/)) {

Is not checking checking BACKEND content at all.

#4 Updated by pcervinka about 2 years ago

  • Status changed from In Progress to Resolved

#5 Updated by jlausuch about 2 years ago

  • Status changed from Resolved to Closed
  • Target version changed from 445 to 457

#6 Updated by pcervinka about 1 year ago

  • Target version changed from 457 to QE Kernel Done

Also available in: Atom PDF