Project

General

Profile

action #53672

Using https://openqa.opensuse.org/admin/needles ran into some problems on the git repo on multi-needle delete

Added by okurz about 2 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Low
Assignee:
Category:
Concrete Bugs
Target version:
-
Start date:
2019-07-02
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

WHen deleting about 100 needles over https://openqa.opensuse.org/admin/needles with about 28 needles left three errors popped up:

Needle deletion

Deletion ongoing, 28 needles remaining…
Outstanding needles Failed needles

    import-untrusted-gpg-key-598D0E63B3FD7E48-42.2-20161012.json
    import-untrusted-gpg-key-598D0E63B3FD7E48-15.0-20180425.json
    firefox_clean-no_reader_view_icon-20171006.json
    yast2_network-applet_warning-20180510.json
    system_role-system-role-admin-boo1087392-20180428.json
    system_role-system-role-admin-selected-20180428.json
    system_role-system-role-plain-selected-20180428.json
    system_role-system-role-plain-20180428.json
    system_role-system-role-worker-selected-20180428.json
    system_role-system-role-worker-20180428.json
    system_role-system-role-default-system-boo1087399-20180427.json
    tryton-login_password-single_dialog-20170714.json
    tryton-module_configuration_wizard-add_users-welcome-20170714.json
    tryton-module_configuration_wizard-add_users_dialog-20170705.json
    tryton-module_configuration_wizard-configuration_done-20170714.json
    tryton-admin_view-20170714.json
    tryton-module_configuration_wizard-next_step-20170714.json
    tryton-manage_profiles-database_selected-20170714.json
    tryton-module_configuration_wizard_start-20170714.json
    yast2_network-applet_warning-20180321.json
    multi_users_dm-user01_selected-20171004.json
    tryton-module_configuration_wizard-configuration_done-20180316.json
    partitioning_togglehome-proposed-separated-swap-20180130.json
    partitioning_togglehome-proposed-separated-swap-20180312.json
    gnucash-save-changes-lxde-20180511.json
    gnome-gnucash-save-changes-20180411.json
    zypper_ref-20141207.json
    zypper_ref-20170322.json



    disable_online_repos-main-repo-non-oss-disabled-text-20171215.json
    Unable to push Git commit: To github.com:os-autoinst/os-autoinst-needles-opensuse.git ! [rejected] master -> master (non-fast-forward) error: failed to push some refs to 'git@github.com:os-autoinst/os-autoinst-needles-opensuse.git' hint: Updates were rejected because the tip of your current branch is behind hint: its remote counterpart. Integrate the remote changes (e.g. hint: 'git pull ...') before pushing again. hint: See the 'Note about fast-forwards' in 'git push --help' for details.
    disable_online_repos-main-repo-oss-disabled-text-20171215.json
    Unable to rm via Git: fatal: Unable to create '/var/lib/openqa/share/tests/opensuse/products/opensuse/needles/.git/index.lock': File exists. Another git process seems to be running in this repository, e.g. an editor opened by 'git commit'. Please make sure all processes are terminated then try again. If it still fails, a git process may have crashed in this repository earlier: remove the file manually to continue.
    desktop-runner-border-kde-leap421-20160819.json
    Unable to rm via Git: fatal: Unable to create '/var/lib/openqa/share/tests/opensuse/products/opensuse/needles/.git/index.lock': File exists. Another git process seems to be running in this repository, e.g. an editor opened by 'git commit'. Please make sure all processes are terminated then try again. If it still fails, a git process may have crashed in this repository earlier: remove the file manually to continue.

Related issues

Is duplicate of openQA Project - coordination #45302: [epic] smarter fetchneedles (was: fetchneedles should ensure we are always on a branch (and try to self-repair))Blocked2019-12-20

History

#1 Updated by okurz about 2 years ago

the other needles were deleted just fine however and also a subsequent save of needles from the needle editor was fine. Also I checked the repo state on o3 and it looks all ok and clean so the self-repair seems to work :) It's rather about "cosmetics" and not confusing the user.

#2 Updated by mkittler almost 2 years ago

  • Assignee deleted (mkittler)

#3 Updated by okurz over 1 year ago

  • Is duplicate of coordination #45302: [epic] smarter fetchneedles (was: fetchneedles should ensure we are always on a branch (and try to self-repair)) added

#4 Updated by okurz over 1 year ago

  • Status changed from New to Rejected
  • Assignee set to okurz

Pretty sure the problem is that the delete took so long that a fetch needles was triggered in parallel locking the git repo

Also available in: Atom PDF