Project

General

Profile

action #52250

package: ffmpeg-4 is unresolvable on SLE_15_SP1 x86_64

Added by okurz over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
-
Start date:
2019-05-28
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

See https://build.opensuse.org/project/monitor/devel:openQA:SLE-15?arch_x86_64=1&defaults=0&repo_SLE_15_SP1=1&unresolvable=1

shows

nothing provides libmysofa-devel, nothing provides pkgconfig(aom), nothing provides pkgconfig(codec2), nothing provides pkgconfig(rubberband), nothing provides pkgconfig(srt), nothing provides pkgconfig(vidstab) >= 0.98, nothing provides pkgconfig(ffnvcodec)

but why not on SLE_15? Where some packages really removed for SLE_15_SP1? Wouldn't be the first time we detect some SLE bugs using devel:openQA ;)


Related issues

Copied to openQA Project - action #52253: package: devel:openQA:SLE-15/perl-DBIx-Class and others are "broken" for SLE_15_SP1Resolved2019-05-28

History

#1 Updated by okurz over 3 years ago

  • Copied to action #52253: package: devel:openQA:SLE-15/perl-DBIx-Class and others are "broken" for SLE_15_SP1 added

#2 Updated by okurz over 3 years ago

  • Status changed from New to Blocked
  • Assignee set to okurz

#3 Updated by okurz over 3 years ago

  • Status changed from Blocked to Workable
  • Assignee deleted (okurz)

mentioned bug VERIFIED FIXED but did not help.

#4 Updated by nicksinger over 3 years ago

Hovering over "unresolvable" shows me:
nothing provides libmysofa-devel, nothing provides pkgconfig(aom), nothing provides pkgconfig(codec2), nothing provides pkgconfig(rubberband), nothing provides pkgconfig(srt), nothing provides pkgconfig(vidstab) >= 0.98, nothing provides pkgconfig(ffnvcodec)

So maybe that's the reason ffmpeg-4 is unresolvable?

#5 Updated by okurz over 3 years ago

well, yeah. That's what the ticket description already says ;)

#6 Updated by okurz over 3 years ago

let's start with the pre-requisities: https://build.opensuse.org/package/show/devel:openQA:SLE-15/opencv shows unresolvables on libavcodec for 15-SP1 aarch64 & ppc64le but not x86_64 and not for 15. https://build.opensuse.org/project/show/home:okurz:branches:KDE:Extra shows the same dep problems however also for 15 aarch64 and ppc64le now. https://build.opensuse.org/project/show/home:okurz:branches:devel:openQA:SLE-15 shows the same as in devel:openQA. I wondered if a rebuild of https://build.opensuse.org/package/show/devel:openQA:SLE-15/opencv would also fail but it seems not because the branch project actually rebuilds and it looks the same.
So where is libavcodec for aarch64 & ppc64le on 15SP1?

#7 Updated by okurz over 3 years ago

  • Status changed from Workable to Feedback
  • Assignee set to okurz
[05/06/2019 09:33:17] <maxlin> okurz[m], nsinger : %if 0%{?suse_version} > 1500 is the problem you seen ffmpeg-4 's unresolvable
[05/06/2019 09:34:04] <maxlin> sp1]s suse_version is 1501, so those build deps now were required
[05/06/2019 09:34:26] <DimStar> maxlin: WHAT? SP1 changed suse_version?
[05/06/2019 09:35:18] <maxlin> yes, it's strange, but.. yes, at least per prjconf it is 1501
[05/06/2019 09:35:19] <DimStar> Leap 15.1 did not - I doubt the two being out of sync is a really smart move
[05/06/2019 09:35:47] <fvogt> WTF
[05/06/2019 09:36:14] <maxlin> but I doubt it was the fallout on OBS only?
[05/06/2019 09:36:23] <DimStar> and IIRC, it was agreed that SLE15 would stick to 1500 for the entire life time - there is sle_version to have the exact SPlevel
[05/06/2019 09:36:40] <okurz> that's exactly I was aiming for, a WTF-session ;)
[05/06/2019 09:36:49] <fvogt> Internally it's still 1500, so just wrong on OBS?
[05/06/2019 09:36:58] <maxlin> fvogt: I supposed that
[05/06/2019 09:37:06] <fvogt> Yup, confirmed
[05/06/2019 09:37:34] <maxlin> DimStar: I thought the same too
[05/06/2019 09:38:06] <fvogt> "   2 (adrianSuSE   2019-01-02 15:09:54   963) %define suse_version 1501"
[05/06/2019 09:38:33] <fvogt> adrianS: ^ s/1501/1500/ on SUSE:SLE-15-SP1:GA please
[05/06/2019 09:38:46] <nsinger> maxlin: lol but thx for pointing us to it

waiting for OBS instance admins to fix it.

#8 Updated by okurz over 3 years ago

so adrianS changed the value of suse_version in https://build.opensuse.org/project/prjconf/SUSE:SLE-15-SP1:GA to 1500 (back from 1501).

I triggered a rebuild of all packages in the repo but it seems that retriggering the building of the complete repo still did not trigger ffmpeg-4 to reconsider the changed suse_version value. I triggered it now with build-disable/enable in the package: https://build.opensuse.org/package/show/devel:openQA:SLE-15/ffmpeg-4

#9 Updated by okurz over 3 years ago

  • Status changed from Feedback to Resolved

So all packages in https://build.opensuse.org/project/show/devel:openQA:SLE-15 are now built correctly, yay! And we fixed SUSE:SLE-15-SP1:GA in the process so that other projects can benefit as well :)

Also available in: Atom PDF