Project

General

Profile

action #4860

action #3136: support remote workers

upload_logs needs to map openqa.suse.de only on local hosts

Added by coolo almost 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
Start date:
2014-11-25
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

upload_logs does a pretty nasty trick to map $OPENQA_HOSTNAME within the VM to a local IP. this only works if the worker runs locally. I guess we should be able to get away without this mapping

History

#1 Updated by oholecek almost 8 years ago

One question, what about the option to run tests in constrained network environment? Like BS workers?
The similar problem is when using TAP devices instead qemu user network, so there should be a note in docs that administrator is to provide DNS.

#2 Updated by coolo almost 8 years ago

BS workers have no network at all - and I think it's pretty boring to test functionality without network. But the problem here is that we try to work around DNS and that fails, so requiring DNS is ok. The problem is that it needs to work within VM - even at times when network setup failed. That was the idea behind it.

#3 Updated by oholecek almost 8 years ago

Apart cgi-proxy or tiny http server ideas, what about using libguestfs?
e.g. standardize that all logs should end up in /var/tmp/openqa/logs (in the VM). Then, after tests finish, they are moved to testresults directory on worker directly from VM disk (e.g. by using guestfs).

#4 Updated by coolo almost 8 years ago

this only works for cases where yast already installed. And you need to know a lot about the disk setup the test did - i.e. RAID,LVM,cryptlvm, ...

I think our easiest solution still is relying on DNS - and only if we get a real problem with it switch back to localhost and proxying.

#5 Updated by coolo almost 8 years ago

even the DNS solution is problematic. The scheduler allows upload_log route only for "allowed_hosts". This would be yet another thing to configure to add a new remote worker - not good ;(

So we need to introduce a shared secret.

#6 Updated by coolo almost 8 years ago

  • Assignee set to coolo

so I had a chat with Bernhard about it and we came to the conclusion that having the uploadlogs in openqa is not necessary. So to also make os-autoinst more self contained I'll implement a HTTP interface in os-autoinst (reusing issue #1308) to store the logs in the pool and the worker can then copy it together with the rest.

#7 Updated by coolo almost 8 years ago

https://github.com/os-autoinst/os-autoinst/pull/123 is the result - openQA worker will need to move back the uploaded logs from pool dir

#8 Updated by coolo almost 8 years ago

  • Category set to 132
  • Status changed from New to Resolved

Also available in: Atom PDF