Project

General

Profile

action #48467

[qam][sle] test fails in zypper_lifecycle_toolchain - increase timeout for installation

Added by pcervinka over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-02-27
Due date:
2019-03-16
% Done:

100%

Estimated time:
10.00 h
Difficulty:
easy

Description

Observation

openQA test in scenario sle-12-SP4-Server-DVD-Updates-x86_64-qam-allpatterns+addons@64bit fails in
zypper_lifecycle_toolchain

Test suite description

All modules defined in SCC_ADDONS

Reproducible

Fails since (at least) Build 20190227-1

Expected result

Last good: 20190226-2 (or more recent)

Further details

Always latest result in this scenario: latest

Test sometimes fails during package installation. Timeout 700s is not enough in case slow network.


Related issues

Is duplicate of openQA Tests - action #47228: [QAM] zypper timeouts before installing all packagesRejected2019-02-06

History

#1 Updated by pcervinka over 2 years ago

  • Subject changed from [qam] test fails in zypper_lifecycle_toolchain - increase timeout for installation to [qam][sle] test fails in zypper_lifecycle_toolchain - increase timeout for installation

#2 Updated by pcervinka over 2 years ago

  • Is duplicate of action #47228: [QAM] zypper timeouts before installing all packages added

#3 Updated by pcervinka over 2 years ago

  • Assignee set to martinsmac

Hi Marcelo. Although it is not a new test development, this could be a good exercise. It is fix improvement of existing test.

#4 Updated by pcervinka over 2 years ago

  • Status changed from New to Rejected

Fix will be provided in related case.

#5 Updated by pcervinka over 2 years ago

  • Status changed from Rejected to New

#6 Updated by martinsmac over 2 years ago

  • Due date set to 2019-03-16
  • Status changed from New to In Progress
  • % Done changed from 0 to 60
  • Estimated time set to 10.00 h

Changes on tests/console/zypper_lifecycle_toolchain.pm

--- zypper_call("in $gcc_packages");
+++ zypper_call("in $gcc_packages" , timeout => 1200);

#8 Updated by martinsmac over 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100
  • Difficulty set to easy

Done, PR approved.

Also available in: Atom PDF