Project

General

Profile

action #45098

[sle][migration][SLE15SP1]test fails in wireshark - unexpect "bad checksum" msg window popup

Added by coolgw almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-12-13
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP1-Installer-DVD-x86_64-offline_sled15_media_basesys+desk+we_all_full@64bit fails in
wireshark

Reproducible

Fails since (at least) Build 104.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by coolgw almost 4 years ago

  • Assignee set to coolgw

#2 Updated by coolgw almost 4 years ago

The checksum maybe caused by workway of nic, seems normal.
https://wiki.wireshark.org/CaptureSetup/Offloading

But i can not find correct way to reproduce this issus.(checksum msg popup automaticly)

#3 Updated by coolgw almost 4 years ago

But i think we can make some improvement to disable offload feature, please refer following link
http://docs.gz.ro/node/282

#4 Updated by coolgw over 3 years ago

  • Status changed from New to In Progress

#5 Updated by coolgw over 3 years ago

  • % Done changed from 0 to 60

#6 Updated by coolgw over 3 years ago

  • Status changed from In Progress to Feedback

Discussion with owner of moudle

#8 Updated by okurz over 3 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: offline_sled15_media_basesys+desk+we_all_full
https://openqa.suse.de/tests/2394039

#9 Updated by coolgw over 3 years ago

Try to rerun and check wireshark configuration whether disable checksum option or not, but encounter issue on openqa.

linux-4360:/home/suse # /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 2367678 _GROUP=0 --skip-download
Created job #2456082: sle-15-SP1-Installer-DVD-x86_64-Build136.2-offline_sles15_media_basesys+srv+desk+we_all_full@64bit -> http://openqa.suse.de/t2456082

[2019-02-13T03:42:47.0825 CET] [debug] Downloading SLE-15-SP1-Installer-DVD-x86_64-Build136.2-Media1.iso - request sent to Cache Service.
[2019-02-13T03:42:52.0876 CET] [debug] Download of SLE-15-SP1-Installer-DVD-x86_64-Build136.2-Media1.iso processed
[2019-02-13T03:42:52.0881 CET] [debug] [INFO] OpenQA::Worker::Cache: loading database from /var/lib/openqa/cache/cache.sqlite
[DEBUG] CACHE: Health: Real size: 50043873792, Configured limit: 53687091200
[INFO] OpenQA::Worker::Cache: Initialized with localhost at /var/lib/openqa/cache, current size is 50043873792
[INFO] Downloading SLE-15-SP1-Installer-DVD-x86_64-Build136.2-Media1.iso from openqa.suse.de/tests/2456082/asset/iso/SLE-15-SP1-Installer-DVD-x86_64-Build136.2-Media1.iso
[DEBUG] CACHE: Download of /var/lib/openqa/cache/openqa.suse.de/SLE-15-SP1-Installer-DVD-x86_64-Build136.2-Media1.iso failed with: 404 - Not Found
[DEBUG] CACHE: requested to remove nonexisting asset /var/lib/openqa/cache/openqa.suse.de/SLE-15-SP1-Installer-DVD-x86_64-Build136.2-Media1.iso

[2019-02-13T03:42:52.0882 CET] [warn] job is missing files, releasing job
[2019-02-13T03:42:52.0927 CET] [info] +++ worker notes +++
[2019-02-13T03:42:52.0927 CET] [info] end time: 2019-02-13 02:42:52
[2019-02-13T03:42:52.0927 CET] [info] result: setup failure: Can't download SLE-15-SP1-Installer-DVD-x86_64-Build136.2-Media1.iso to /var/lib/openqa/cache/openqa.suse.de/SLE-15-SP1-Installer-DVD-x86_64-Build136.2-Media1.iso
[2019-02-13T03:42:52.0927 CET] [info] uploading autoinst-log.txt

#11 Updated by coolgw over 3 years ago

  • Status changed from Feedback to Resolved

PR merged.
If issue happen again, we can reopen it.

#12 Updated by coolgw over 3 years ago

  • Status changed from Resolved to In Progress

#13 Updated by coolgw over 3 years ago

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/6885 new improvement PR submitted base on Oliver's comment.

#14 Updated by coolgw over 3 years ago

  • Status changed from In Progress to Resolved

No found issue on 181.3 review, so just put resolved state, reopen it if still exist issue.

#15 Updated by leli over 3 years ago

  • Status changed from Resolved to In Progress

Reopen it since found this on build 186.1.
https://openqa.suse.de/tests/2529377#step/wireshark/83

#17 Updated by okurz over 3 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: offline_sled15_media_basesys+desk+we_def_full
https://openqa.suse.de/tests/2493356

#18 Updated by coolgw over 3 years ago

rerun:
linux-4360:/home/suse/openqa-code/os-autoinst # /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 2703659 --skip-download _GROUP=0
Created job #2747276: sle-15-SP1-Installer-DVD-POST-x86_64-Build190.3-offline_sled15_media_basesys+desk+we_def_full@64bit -> http://openqa.suse.de/t2747276

#19 Updated by coolgw over 3 years ago

last run block on patch, so rerun:
https://openqa.suse.de/tests/2747365

#20 Updated by coolgw over 3 years ago

coolgw wrote:

last run block on patch, so rerun:
https://openqa.suse.de/tests/2747365

failed on patch sle again

#21 Updated by coolgw over 3 years ago

linux-4360:/home/suse/test # for i in {001..5} ; do ./openqa_clone_job_o3 --skip-chained-deps 2747365 TEST=gaow_poo2495012_$i BUILD=poo2495012_investigation _GROUP="Test Development: openSUSE Tumbleweed" ; done
Created job #2751045: sle-15-SP1-Installer-DVD-POST-x86_64-Build190.3-offline_sled15_media_basesys+desk+we_def_full@64bit -> http://openqa.suse.de/t2751045
Created job #2751046: sle-15-SP1-Installer-DVD-POST-x86_64-Build190.3-offline_sled15_media_basesys+desk+we_def_full@64bit -> http://openqa.suse.de/t2751046
Created job #2751047: sle-15-SP1-Installer-DVD-POST-x86_64-Build190.3-offline_sled15_media_basesys+desk+we_def_full@64bit -> http://openqa.suse.de/t2751047
Created job #2751048: sle-15-SP1-Installer-DVD-POST-x86_64-Build190.3-offline_sled15_media_basesys+desk+we_def_full@64bit -> http://openqa.suse.de/t2751048
Created job #2751049: sle-15-SP1-Installer-DVD-POST-x86_64-Build190.3-offline_sled15_media_basesys+desk+we_def_full@64bit -> http://openqa.suse.de/t2751049
linux-4360:/home/suse/test #

#22 Updated by coolgw over 3 years ago

  • Status changed from In Progress to Resolved

coolgw wrote:

linux-4360:/home/suse/test # for i in {001..5} ; do ./openqa_clone_job_o3 --skip-chained-deps 2747365 TEST=gaow_poo2495012_$i BUILD=poo2495012_investigation _GROUP="Test Development: openSUSE Tumbleweed" ; done
Created job #2751045: sle-15-SP1-Installer-DVD-POST-x86_64-Build190.3-offline_sled15_media_basesys+desk+we_def_full@64bit -> http://openqa.suse.de/t2751045
Created job #2751046: sle-15-SP1-Installer-DVD-POST-x86_64-Build190.3-offline_sled15_media_basesys+desk+we_def_full@64bit -> http://openqa.suse.de/t2751046
Created job #2751047: sle-15-SP1-Installer-DVD-POST-x86_64-Build190.3-offline_sled15_media_basesys+desk+we_def_full@64bit -> http://openqa.suse.de/t2751047
Created job #2751048: sle-15-SP1-Installer-DVD-POST-x86_64-Build190.3-offline_sled15_media_basesys+desk+we_def_full@64bit -> http://openqa.suse.de/t2751048
Created job #2751049: sle-15-SP1-Installer-DVD-POST-x86_64-Build190.3-offline_sled15_media_basesys+desk+we_def_full@64bit -> http://openqa.suse.de/t2751049
linux-4360:/home/suse/test #
wireshark part not found checksum error, close it firstly, if still checksum error popup then we reopen it and fix

#23 Updated by hjluo over 3 years ago

  • Status changed from Resolved to In Progress

#24 Updated by okurz over 3 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: offline_sled15_media_basesys+desk+we_all_full
https://openqa.suse.de/tests/2804542

#25 Updated by coolgw over 3 years ago

  • Assignee changed from coolgw to hjluo

#26 Updated by hjluo over 3 years ago

We send_key alt+c to close this window but it failed. now thinking ways to make sure alt+c can close this window once hit.

#27 Updated by hjluo over 3 years ago

it also failed with this issue on the run of https://openqa.suse.de/tests/2804542#step/wireshark/84

#28 Updated by hjluo over 3 years ago

try to send_key 'alt-f4' to close the pop up window instead of 'alt_c'.

#30 Updated by hjluo over 3 years ago

#33 Updated by hjluo over 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

Also available in: Atom PDF